Breaking nvidia dependency on update

While trying either yay or sudo pacman -Syu I’m seeing the following:

resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (550.67-1) breaks dependency 'nvidia-utils=550.54.14' required by lib32-nvidia-utils

Very similar to this thread so I tried the solution there but yay nvidia | grep installed only returns a flashing curser in the terminal.

I’m not finding any other potential solutions searching the community or online, would appreciate some help with this!

Inxi: https://0x0.st/Xs1E.txt

The most common cause for that error is that you overwrote your pacman.conf from a pacnew which disabled multilib repo.

Check your /etc/pacman.conf and ensure you have both the endeavouros repo and the multilib repo enabled.

I see multilib in the /etc/pacman.conf but I don’t see any endavouros repo there. Updated mirrors again but it didn’t change anything.

Looking at this, would it simply be removing the second hash at #[multilib] #Include = /etc/pacman.d/mirrorlist

Repositories section of pacman.conf:

# REPOSITORIES

# - can be defined here or included from another file

# - pacman will search repositories in the order defined here

# - local/custom mirrors can be added here or in separate files

# - repositories listed first will take precedence when packages

# have identical names, regardless of version number

# - URLs will have $repo replaced by the name of the current repo

# - URLs will have $arch replaced by the name of the architecture

# Repository entries are of the format:

# [repo-name]

# Server = ServerName

# Include = IncludePath

# The header [repo-name] is crucial - it must be present and

# uncommented to enable the repo.

# The testing repositories are disabled by default. To enable, uncomment the

# repo name header and Include lines. You can add preferred servers immediately

# after the header, and they will be used before the default mirrors.

#[core-testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

#[extra-testing]
#Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,

# enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

#[multilib]
#Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository. See the pacman manpage for

# tips on creating your own repositories.

#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

multilib is commented out. Also, if you are using endeavouros, you need our repo too. That is a stock pacman config meaning you overwrote your pacman.conf.

You can overwrite it with a working copy from eos with this command:

curl https://raw.githubusercontent.com/endeavouros-team/EndeavourOS-ISO/main/airootfs/etc/pacman.conf | sudo tee /etc/pacman.conf
1 Like

That fixed it right away. I would not have found that very quickly on my own, if ever. Thank you very much for your help! Now I know what I’m looking for in an etc/pacman.conf :+1:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.