Bottles games and steam launcher crash in discete GPU mode

Hello,When i launch steam launcher or bottles game in discrete GPU mode.they always crash.i have optimus laptop with nvidia GTX 820M dGPU and intel iGPU.there is no propritary nvidia support for current bulid EndeavourOS.So i use nouveau driver with wayland KDE.they have no issue with iGPU but low performance.

Please someone help me fix this issue.i am just a just newbie linux user.i only knows basic comandline and basic english skill.

inxi -Gzxx
  Device-1: Intel Haswell-ULT Integrated Graphics
    vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-7.5 ports:
    active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:0a16
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
    620M/625M/630M/720M] vendor: Acer Incorporated ALI driver: nouveau
    v: kernel arch: Fermi pcie: speed: 2.5 GT/s lanes: 4 bus-ID: 04:00.0
    chip-ID: 10de:1140
  Device-3: Sunplus Innovation HD WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 2-5:5 chip-ID: 1bcf:2c17
  Display: wayland server: v: with: Xwayland v: 23.1.2
    compositor: kwin_wayland driver: X: loaded: intel,nouveau
    unloaded: modesetting alternate: fbdev,nv,vesa dri: i965,nouveau
    gpu: i915,nouveau display-ID: 0
  Monitor-1: eDP-1 res: 1366x768 size: N/A
  API: OpenGL v: 4.6 Mesa 23.1.3 renderer: Mesa Intel HD Graphics 4400 (HSW
    GT2) direct-render
1 Like

If you didn’t get this issue, here is how I managed to get this GPU set up mostly properly, pretty much the best it’s been running on any distro I tried.

To sum it up. This GPU only supports nvidia-390xx drivers, and no later.
nouveau also has no official support for the 820m so it doesn’t perform well.

Installed a package nvidia-inst and ran
nvidia-inst -t --series 390 --bumblebee --32

This checked the setup, and listed out a series of commands, most of which you should perform as root, except yay.

In the end, check the kernel parameters where nvidia-drm.modeset=1 was added, if there is nomodeset also there from a previous setup. It was keeping my system in terminal only mode, causing a black screen. I use grub so removing it from /etc/default/grub and running sudo grub-mkconfig -o /boot/grub/grub.cfg fixed it.

Steam had the same crashing issue, but now seems to run with no problem.

1 Like

now i’m working on nvidia-390xx-dksm with envycontrol .this is my old tread.forgot to tag SOLVED ,but thanks to reply

i had was use neuvou driver bc i needed to test wayland.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.