Borderlands 3 Doesn't Run on Lutris


I just got Borderlands 3 on the Epic Games Store via Lutris. When I start up the game, the splash screen shows up and then it closes. I tried to fix this issue by using the install on Lutris, but that was to no avail. Here is the log for the error messages. What can I do to fix this?

EDIT: This error message also shows up.

I’m not too sure if this will help,
Also maybe have a look here

I did try that first link you sent, but the error still persists. I suppose I should mention that I ran the executable directly rather than run it from the Epic Games Store, and then launched Borderlands 3. I’m thinking that’s the problem; but I can’t say yet. I’ll have to try launching the game from EGS and see if anything has changed. If there’s anything notable, I’ll come back here to report my findings.

Some games can be tricky to get up and running, I normally look at protonDB or WineHQ to try find a fix or ideas to get them running. Hopefully you can get it up and running as it is a great game.

Update: The game now boots.

Initially, booting the game from EGS gave me this message:
wine: Call from 000000007B0124DE to unimplemented function mfplat.dll.MFGetConfigurationDWORD, aborting

To fix this, all I had to do was go into Wine Configuration, “Libraries”, “mf”, and then select edit to change its load order to “builtin”.

1 Like

Awesome, have fun playing

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.