Boots to black screen cant open terminal

Hi linux noob here,

I installed Endeavor OS yesterday and I liked it a lot, but when I turned it back on it would boot to a blank screen. I tried to open a console with ctrl + alt + f2 but nothing happened.

Can someone help me out?

Welcome to the community :beers:

So you had a full and working install that you were able to get into a DE on? When you boot now, what does it show before you hit any keys? Normally hitting ctrl+alt+f2 will take you to a tty session, which is just a terminal session (more or less), so it being a black screen is expected.

Thank you :smiley:

Yes the only major thing I could think of that would mess things up was using akm to download the lts kernel and kernel headers.

Starting version 246.6-1-arch
/dev/sda2: clean, 492114/61030400 files

Then it cuts to black

Adding options via AKM shouldn’t throw anything off. Do you get options in the grub menu when you boot? Have you tried all of them, just to be sure?

Yes I did get multiple options

En Os, on linux
En Os, on linux (fallback)
En Os, on linux lts
En Os, on linux lts (fallback)

Unfortunately all of them gave the same result

Quick question–are you using the nVidia driver? If so, did you install nvidia-dkms?

No im useing the free drivers
( amd rx580)

OK–it was just a thought…I’ve done that in the past with the same result you had.

I did see some posts about nvidia driver problems

I would guess its a display/driver issue, but I’m far from an expert in that stuff, so I’ll have to let somebody else take over from here. Maybe start by posting the output of inxi -Fxxxrza, I think that will give the needed system info for somebody else to take it from here. If that cmd fails for you, just do yay inxi and install it from there.

I dont want to sound stupid but, I would need to open a tty session for that right?

Because if so I don’t think I can

Just a thought—try ctrl + alt + f3 or f4 or f5—I think that the “normal” session is in f2.

Let me try that

No dice :pensive:

It was worth a shot

OK–so what you have is before the main system comes up…That happened to me when I had only kernels without (in my case) the nvidia driver installed… Not sure if there is an analogue to “nvidia-dkms” for AMD, but I would guess that is the case. I’m an nvidia guy, so at the end of what I can help with. I do goto Arch forums & Wiki when I’m at a loss…lots of good info there.

Ill check it out

I’ll check back & see if you’ve got an answer…or if one of the AMD guys knows…Luck & good talking with you.

You can boot off the live ISO and install inxi and then run the command and post the output for your hardware.

1 Like

I try that in the morning I’m too tired to think straight :laughing:

I post the output if It works

1 Like

Have you waited for at least 2 minutes to see if the machine eventually boots? There’s a bug I know of that can delay boot for 1 1/2 - 2 minutes.