Booting into black screen after update

I should preface, that I know not very much about endeavouros, it is my system exclusively because a (now ex) girlfriend installed it onto my new computer without me really having much control or input or being told anything about troubleshooting

after updating en masse today (i only update once every week/two weeks) i rebooted my computer, loaded into the current archlinux setup, only to have my computer:

  1. skip the login entirely (i have it set up so that i have to put in my password every time i log in, even i was just away from my computer for 10 or so minutes, to make sure i remember it)
  2. my desktop environment did not load, no taskbar, i can’t access my system settings, however other apps did open automatically, such as Firefox, which opened the tabs i’d had open before i rebooted.

As such, the only way for me to access the command console was through a shortcut i’d put in (ctrl+alt+t) (i may not have put this in but i couldnt find the shortcut online and thus assume it was one that either i or my ex had put in)
using the console, i was able to downgrade to an earlier version of archlinux, which does work, (system settings/task bar/app launcher all accessible) but obviously this won’t be a very good fix for long (also for some reason on the older linux my kwin_wayland takes up an absurd amount of CPU (around 50-70%) which does not seem to be an issue in the newer iteration of arch (that being the one that loads into a black screen)
i can try to post other logs that might be helpful but as i prefaced i have basically no clue how to GET those logs so it might take me a moment
I am hoping this is a fairly straightforward fix simply using some command or diagnostic tool i’m unaware of, but the situation does seem rather odd

1 Like

I was having the same problem, but at least I got to the login screen. After logging in, I got the blank screen. Lucky for me I always leave firefox open, so it opened automatically. But what solved my problem was: at the login screen, i noticed on the corner it was set to Wayland session. I clicked it to change to X11 (what I previously used), and voi là, problem solved.

1 Like

This is good news! for at least everything I’d searched for online, I’d been led to the belief that I simply needed to get to the login screen and change this setting!

the issue that now remains is finding a way to get to this screen, but this is very good news nonetheless

Unfortunately I’m also not very experienced with Linux/EndeavourOS, I hope I could be more helpful.

i managed to get to the login screen but there was no option to switch the session, so i guess i’ll have to figure something else out

i was facing some graphical issues (lots of flickering) after the update, changing from Wayland to X11 seems to have solved the issue for now.

not exactly sure why Wayland is causing all these visual glitches though?

EDIT: i am using Nvidia, seems like Nvidia and Wayland cause issues

1 Like

In my screen, it was at the bottom left corner, a small rectangle besides the Virtual Keyboard clickable thingie.