Booting Directly to TTY

Not sure if this is the correct section or not. I updated one of my machines today after several weeks and upon reboot it goes directly to into TTY. System is using systemd-boot and EFI, no grub. I tried fallback, that does the same. Tried installing zen, that does the same. Was hoping LTS would fix this, but it goes straight to TTY also.

Kernel 6.2.9
Kwin window manager
Intel Pentium 3558U dual core
Integrated graphics

It’s showing an error that I can’t read all of when I try startx that xterm not found/etc/X11/xinit/xinitrc

Install the xorg-xinit package.

What DE and display-manager were you using?

Xorg-xinit is installed


Might need a reinstall, since /etc/X11/xinit/xinitrc isn’t found.

sudo cp /etc/X11/xinit/xinitrc ~/.xinitrc

See the Arch Wiki:

nano ~/.xinitrc

Append the following line to ~/.xinitrc
exec startlxqt

You might want to sudo systemctl disable sddm.service and use startx to get into your DE then…

Not gonna lie, this is over my head. I obviously messed up something with

Installed plasma and Wayland and ran startplasma-wayland and got to a functioning GUI desktop.
If I log out, it drops back to TTY rather than the lock screen.

Ah… before you said, you use LXQT. Now you suddenly use Plasma? Thanks for the confusion. :umpf:

This means, your DM-service isn’t activated, but Plasma is started via startx, which is then normal behavior.

Generally two ways to start a DE:

Via DM or startx. Can’t use both at the same time. The advantage of doing startx to me is, you can update your system and reboot, before starting the DE which is generally much faster.

Sorry for the confusion, I tried startx and startlxqt, neither worked. No usable desktop GUI could be reached.
From TTY I installed plasma and Wayland and ran startplasma-wayland just to see what would happen. But yes, as you point out, the DM-service isn’t activated or activating properly I’m guessing. But why does it reach a usable GUI with Wayland but not X11?

Please see my longer post above.

To start Plasma with xinit/startx, append
export DESKTOP_SESSION=plasma
exec startplasma-x11
to your .xinitrc file.


If you like to go the other way, via DM as you apparently have been used to, look here:

That way you can choose to boot into Plasma or Lxqt from the DM’s greeter (“login-page” as you named it).

In that case it makes sense to either delete the previously edited ~/.xinitrc (in your home-folder), or just overwrite it with the xorg-xinit standard-file, via:
sudo cp /etc/X11/xinit/xinitrc ~/.xinitrc


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.