Boot stuck at Reached target Graphical Interface

After doing a system upgrade plasma updated to version 6 and I was encountering a couple of errors and searching online apparently I had to enable in pacman’s config extra-testing. After another system upgrade none of the apps worked so i rebooted my system and now I’m stuck. I’ve already tryied stuff like startx but it just opens 3 random terminals. Any ideas how to fix this?

Not sure what were your initial issues that would have needed packages from extra-testing to resolve.

Also, you cannot upgrade to the testing repos only by enabling one of the testing repos.
You need to enable them both: core-testing and extra-testing.

I’m afraid you may have created a bigger issue now, than the ones you intended to resolve initially.

Ops I guess… Maybe a live usb to edit again pacman configs and a -Syyu are enough?

That would be what I would try.

We should hope that you will get your system to a bootable state so that you could post here about your initial issues and get help from KDE Plasma users on the forum to start troubleshooting.


If you want to downgrade your packags, then you need to pass -uu that is: pacman -Syuu

I’ve tryied but I’m getting a ton of errors saying that x file exists in filesystem so none of the packages gets updated

You’ve got a bit of a mess on your hand to resolve. :wink:

In chroot, first of all disable the testing repos in /etc/pacman.conf.

Then run:

pacman -Syuu --overwrite '*'

to get your packages back to their versions in the stable repos.

Ok thanks it worked, now I’ll try fixing plasma’s error, this time without breaking everything :joy:

1 Like

Nice! Good luck!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.