Boot stalls at "[ OK ] Reached target Graphical Interface."

This is on a Lenovo Y700 with a GTX960m and Core i7 6000 series that has integrated graphics.

So last night I finally decided to start fresh and drop PopOS on my laptop for Endeavour. The install went beautifully and the computer was running great post-install.

Then I did nvidia-inst --32 -p --conf and the laptop now stalls at the line in the title. I don’t want to say it hangs because that would imply non-responsiveness but everything works fine if I switch to another tty and log in just via the command line.

Over to the right while I type this there are suggested similar topics… I’ve looked through several and most are related to system updates. Looking at the Xorg log after manually attempting to startx it looks like it doesn’t even see the gpu, with “(EE) No devices detected.” after the line saying that 535.113.01 is loaded and NVIDIA Unified Driver has loaded.

My guess is that these drivers must not support the 960M? But based on the documentation for nvidia-inst it sounds to me like it should have either installed whatever was supported or thrown an error that the card is too old. But even that doesn’t make sense because under PopOS I was on the 53x series nvidia drivers and things were working…

Any thoughts?

The 960m should be supported by the 535 driver.

Can you share some output from the TTY:

cat /proc/cmdline
pacman -Q | grep -E "nvidia|linux"
cat /etc/dracut.conf.d/*
1 Like

Yeah I know it was running on that driver last night under PopOS, so I have no idea what changed! I also did double check and the discreet card is enabled in the BIOS.

Respective order to the lines requested :slight_smile:

You didn’t share the output for this one.

Hmm something weird going on with eos-sendlog… that middle link is the result of:

pacman -Q | grep -E “nvidia|linux” | eos-sendlog

Heres just a photo of the output

I don’t see anything strange there.

See if there is an error in xorg logs

I pointed out the xorg error in the OP, but heres the raw:

its not zero 0 it is an O :wink:

You can always reset to nouveau driver from nvidia…
nvidia-inst -n

And by default on optimus systems if Nvidia propritary driver is properly installed will by default boot on the igpu (intel) – i see you have nvidia-prime installed this should not be any issue… but is anything else setup to handle gpu switching?

in case it could also help to simply rebuild modules and initramfs images:
sudo pacman -S nvidia-dkms
sudo reinstall-kernels

you could also try:

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

from TTY to see if this pipes the output to the display…