Boot sequence hang on line : [ OK ] Reached target graphical interface

Rtx 4000 SFF
Ryzen 5900x (no iGPU, X570 mobo)
32 gb ddr4 3800 mhz RAM (running at JDEC 2333 or so, long story)
Nvme Pcie gen 5 ssd

I’ll thank anyone reading this for forgiving me for being brief under the circumstances; I don’t have a keyboard so this is rather unergonomic to document.

I have recently come to EndeavorOS for a variety of reasons, and so I have a fairly fresh installation with packages mainly relating to gaming and web development. This includes Docker, and some Postgres databases running on bare metal. I also have jre runtime and jre runtime headless installed and ignored for personal reasons though I deem these to be unrelated to the issue at hand.

One of the first things I did on installation was use an included utility (on EOS KDE) to determine the fastest mirror automatically.

My issue basically started with the current release cycle for nvidia drivers started; nvidia utilities had an update to 545.29.02-3 before the rest of my nvidia packages updated, causing a conflict.

During this conflict, I manually ignored the nvidia untils package when updating until everything else caught up.

Recently they did, and so I performed a full upgrade with pacman -Syu (I did try yay -Syu from tty after my issue began), and my system continued performing as expected, so I rebooted.

On reboot, I have been frustratingly stuck in the boot process at
Reached target graphical interface

I did leave it hanging on this line for quite a while, roughly twenty minutes or so in case some drivers were compiling after the update or such.

As I specified above. Some interesting lines preceding it include:

Starting Docker Application Container Engine…
Started Docker Container Engine
Reached target Multi-User System

Regardless, I have included some logs with the journalCTL logs redacted until the relevant locations in case of any personal information being present. If a more complete log is required, please let me know.

Anyway, I’ve seen a common piece of advice is to install the dkms packages though I’ve never done so, so I’m not sure precisely which packages I need to remove to do so safely.

Any advice on which direction to go would be much appreciated, and please feel free to ask for any further logs.

try to downgrade the nvidia package

It’s worth noting that downgrading might be a bit tricky because once the nvidia and nvidia-utils packages were ready to update together there were quite a few other packages related to and depending on them which also updated (though I focused on them specifically because it seems other people with similar issues fixed it with some permutation of removing them and installing variants of those packages.

I’ll give it a shot tonight if there’s no other suggestions by then, though.

Fiddling with package versions is better to avoid unless there’s a compelling reason to do so.
Arch based systems do not support partial updates.

And as an Nvidia driver it is better to use nvidia-dkms instead of nvidia (remember to install kernel header package too). Dkms packages are preferred because they work with all official kernels.

For the record, please show the output of

LANG=C pacman -Qs nvidia

LANG=C pacman Qs nvidia

egl-wayland 2:1.1.13-1
lib32-nvidia-utils 545.29.02-3
libvdpau 1.5-2
nvidia-dkms 545.29.02-2
nvidia-utils 545.29.02-2
nvtop 3.0.2-1

I tried uninstalling the main nvidia package and replacing it with the nvidia dkms package, but it’s still giving me the same issue. It occurs to me that it may be related to the varying versions on lib32 nvidia utils (note the -3) compared to the other packages, though I’m not confident on what to do about it.

I do have
linux-headers 6.5.9.arch2-1

If that’s the package needed for dkms drivers. I didn’t do any steps other than pacman -S nvidia-dkms.

It’s also worth noting I didn’t install specific versions of the nvidia utilities; these were all a result of pacman / repos.

hi all,
I solved with
sudo dracut-rebuild after doing reinstall video drivers

I had [ OK ] Reached target graphical interface] message at boot after a yay command
I have a K420 Quadro vga so I used to install nvidia-470xx-dkms drivers

MY steps:
(removed any kernel but LTS ) > pacman -Rc linux linux-headers
(install nvidia dkms) >yay -Syu --needed nvidia-470xx-dkms nvidia-470xx-utils nvidia-470xx-settings
(rebuild initramfs) >sudo dracut-rebuild

this worked for me. But I got legacy nvidia card, I don’t know if this will work for others