Boot problem after updating

Hello, there is a problem, updated the whole system sudo pacman -Syu, then rebooted and stopped working normal scrolling touchpad, climbed into the directory /etc/X11 and in some file actually “turned on” invert touchpad again rebooted and the computer does not want to turn on this point:
/dev/sda2: clean, 324531/6045690 files, etc

How do I roll back all the changes that led to such a problem? Thanks

You running a rolling-release distro so there’s no turning back after a upgrade unless you have made a backup. Are you able to switch to tty2? alt + f2 +ctrl

I have already done this and deleted all the changes in the /etc/X11 folder that led to the problem, everything is already fine, thank you for your answer

1 Like

Welcome to EnOS’ forum @crocus!

Knowing how to chroot from a live session is essential in some cases to do some reparation and maintenance. Please refer to the following link for a how-to:

Also in the event that rolling back on some updates is necessary:



Thanks for giving EndeavourOS a try, and welcome to the forum. I hope you enjoy your time here.

Looks like you solved your problem. If you consider this solved, go to the post you feel most helped you solve the problem. Click on the three horizontal dots next to Reply, then click on “Solution”


1 Like