Boot partition keeps on removing its flags keeps failing for some reason

On a UEFI system, I am trying to setup an lvm partition.

I did this by typing in the following commands as root:
cryptsetup luksFormat /dev/sda2
cryptsetup luksOpen /dev/sda2 crypt
vgcreate lvgroup /dev/mapper/crypt

I wanted to create 3 lvgroups, so I typed this:
lvcreate -n crypt_root -L 10G lvgroup
lvcreate -n crypt_home -L 7G lvgroup
lvcreate -n crypt_swap -l 100%FREE lvgroup

which worked just fine.

So I want into the installation and I mounted both the /home and / partitions (I couldn’t figure out how to mount the /swap partition simply cause there was no option).

Now I wanted to mount the boot partition located on sda1 and I mounted as /boot/efi. These are the options I chose.

When I went to the next screen I saw this message.
image

So I went back to edit the boot partition but it keeps on deselecting the flag I set it to. I am not too sure why this is happening.

Hello @unix_lover
Are you doing this from the installer screen?

Edit: If that’s the case. I usually close the installer and open gparted and set the flag and then it usually doesn’t being up that window. This happens sometimes to me on a normal setup. I don’t use LVM so you could try it and see.

Hey man whats up?

I created the LVM partitions through terminal but the mounting part is done through the calamares installer.

Just use gparted from the menu and device manage flags and set the efi partition as you just did.

Edit: Been a while since i notice any activity. :grin:

1 Like

Ah I see, that works just fine :slight_smile: I set the boot and esp flags. What does esp flag even mean if you happen to know?

Yeah long time no see mate glad I am back :slight_smile: Life got too busy.

It’s just another term for the EFI partition. I think it’s Extensible System Partition? Where as EFI is Extensible Firmware Interface. :man_shrugging: Don’t know why?

1 Like

Ah I see :slight_smile:

It worked for you though? I think it’s just a bug in Clamares? But not sure. It does happen once in a while to me also.

So … how are you getting along with EndeavourOS?

I guess it could be simply cause it keeps deselecting the flags that I set.

Lol it just hung up while installing (I couldn’t move around the windows or anything) so I am trying it again.

No i meant not with this install but in general how you like EndeavourOS.

I haven’t been using it at all I was a bit too busy to set it up on my new PC actually. But yeah I am now going to give it a chance.

Also I kinda have to now migrate to Linux as on Windows it has some strange behaviour with my graphics card. I was running an old game and I believe the graphics card itself was making some weird screeching sound and like the movement in some areas was just screwed. When I ran the same Windows game on Linux (through wine) on a live ISO it ran perfectly, no screeching sound and the movement was fine. I am not too sure why that is.


I am a little curious about something. I have tested both ArchLabs and EndeavourOS on VirtualBox, but why is it that if I install a WM such as awesome or spectrwm, when using any terminal emulator on EndeavourOS it seems to have a bit of a lag when typing but on ArchLabs it seems smooth and fine? They are both based on Arch Linux. Would you know by any chance?

Edit: On both of these OSs, I ran glmark2 benchmark and the score that I got was off by a 1 number difference which means they both performed pretty much exactly the same so I don’t quite get that logic as to why there is text lag when typing on the terminal on EndeavourOS?

That’s because swap isn’t a mountable partition :wink:

1 Like

Were they using the same environment? Afaik ArchLabs comes with many WM options, so if you’re comparing something like i3 vs xfce, there might be some differences. You also have to note what terminal emulators each of them is using.

Oh lol didn’t realise that :slight_smile:

On both ArchLabs and EndeavourOS I installed the exact same WMs which were spectrwm and awesome. And I have used alacritty and other terminal emulators on both these systems and I don’t really know why EndeavourOS has this lag when it comes to writing text on terminals. With ArchLabs it was laggy when using xfce just as much with EndeavourOS. I am not too sure why these WMs lag a lot less though?

So eventually I get an error message after attempting to install it after a long time:

Notice how it says no space left on device. I belive this could be due to the fact that I need to allocate lots of RAM to it. I allocated 4GB of RAM (on virtualbox) still I am getting this?

I’ll have to look at that myself before I can comment :slight_smile:

1 Like

4 is good enough amount of RAM.

We’re you doing an online install? If yes, how many packages did you select?

1 Like

Just installing xfce and base install. Not too sure why this happened?

Offline or online?