Boot menu has two EndeavourOS options

I previously used Fedora and didn’t have this issue. When I installed EndeavourOS, there are now two Linux entries, both leading to the same OS. It’s not two partitions because I formatted the disk where Fedora was. The first two entries are EndeavourOS, the third is Windows, and the fourth is TailsOS. Is it normal for EndeavourOS to have two boot options? (Every OS is on a separate drive. This is my first time using Arch based distro. i tried removing Windows and TailsOS drive but it was still there.)

I guess the second one should be the fallback boot option. systemd-boot (bootctl install) will normally install the bootloader’s efi binary into two locations.

Use bootctl(1) to install systemd-boot to the ESP:

bootctl install

This will copy the systemd-boot UEFI boot manager to the ESP, create a UEFI boot entry for it and set it as the first in the UEFI boot order.

  • On an x64 UEFI, /usr/lib/systemd/boot/efi/systemd-bootx64.efi will be copied to esp/EFI/systemd/systemd-bootx64.efi and esp/EFI/BOOT/BOOTX64.EFI.


If you want you could post the output of:


so that we can have a look.

1 Like

That is normal. You can either boot the named EFI entry or the default EFI entry for the disk.

It is worth noting that at some point Windows will update and take over the default/fallback entry so that one might not always be Linux.

1 Like

In EndeavourOS install I chose systemd-bootloader, are you asking about that?

(This may sound dumb but i asked Cloude 3.5 Sonnet about whis and sent him a few pictures and he said it was ok and that i should boot on UEFI OS option.)

It is OK, but you should boot using the Linux Boot Manager option for the reason I described above.

Thank you, that that I always used was Linux Boot Manager but when curiosity got me I wanted to see what would happen when I boot i UEFI OS and i loaded faster.

1 Like

It is doing the same thing either way. Neither option should be faster.

1 Like

Oh, understood. Thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.