Boot from USB results in a black screen with white text, no progress

I’m having a difficult time using the ISO installing the OS. Basically I have some screen where it tells me what I’m attempting to install, something about, and it just hangs there forever. It’s very similar to the screen in this users post: Issues Installing

I talked to some people on a more general linux chatroom and they suggested that my hardware might be “too new” for the OS. Is that likely true? And if not what do you recommend?

ISO is the newest as of this post. My PC is running a Ryzen 5900x, a 3080 graphics card, an X570 motherboard. I set up the USB stick with Etcher.

Hello @winston
I wonder if it’s the RTX3080 Graphics card causing the issue. Etcher should be fine although now I’m using popsicle-git on EndeavourOS. Try using nomodeset and see what happens. If it works and you can install make sure you select nvidia drivers in the online install.

Edit: Let us know if that doesn’t work.

Edit2: Here is a link to an Nvidia enabled ISO if that doesn’t work.


It actually worked perfectly this time! I didn’t do anything different at all. I’m typing this message from my new Endeavour install.

I think what might have happened is that I tried to install the OS immediately after I set up my new PC. However I was having a hard time getting Windows to “get” that I was using a 3080. My theory is that whatever I did in my motherboard bios settings (GEN3 vs GEN4 settings regarding my riser cable for my SFF case) also resulted in Endeavour’s installer proceeding like normal. Thanks for your help!

current ISO is Nvidia enabled if you choose Nvidia boot option. This very old Nvidia ISO should not be used anymore, and the included Nvidia Driver is way to old to work with the GPU used by Poster.

My bad , I forget the new ISO does have Nvidia on it. :man_facepalming: