Boot failing device not found

Same problem here I think. I get following error message when trying to boot

Waiting 10 seconds for device /dev/diskby-uuid/uuid
ERROR: device ‘UUID=uuid’ not found. Skipping fsck.
mounting UUID=uuid on real root
mount: /new_root: can’t find UUID=uuid

After booting from a live USB I saw that the entire /dev directory is empty, which explains, why udev couldn’t find the device-by-uuid.
The question is, how do I get my /dev back? And, probably more important, should I file a bugreport?

This is a pretty common error. It basically means “something has happened” and your root device is not found.

There are many reasons this can be and we should troubleshoot them separately as it can get confusing if they are lumped together.

Can you please share the output of lsblk -o name,type,fstype,size,uuid and the contents of /etc/fstab.

Also, is this a recent install or is it an existing install.

My lsblk:

NAME                                          TYPE  FSTYPE        SIZE UUID
loop0                                         loop  squashfs      1.7G 
sda                                           disk              298.1G 
├─sda1                                        part  crypto_LUKS   290G e83265a6-a0a0-41ad-83c2-f15dd1770c5e
│ └─luks-e83265a6-a0a0-41ad-83c2-f15dd1770c5e crypt btrfs       289.9G c52c2fe0-78b0-44b8-81f6-ec0116a192f2
└─sda2                                        part  crypto_LUKS   8.1G c09a9faf-b678-4976-a817-2cd84e0c58c5
sdb                                           disk  iso9660      29.3G 2022-12-17-15-01-34-00
├─sdb1                                        part  iso9660       1.8G 2022-12-17-15-01-34-00
└─sdb2                                        part  vfat          105M A59C-8529
sdc                                           disk               57.3G 
└─sdc1                                        part  vfat         57.3G 1CE6-F36A
sr0                                           rom                1024M 

and my fstab:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
/dev/mapper/luks-e83265a6-a0a0-41ad-83c2-f15dd1770c5e /              btrfs   subvol=/@,defaults,noatime,compress=zstd 0 0
/dev/mapper/luks-e83265a6-a0a0-41ad-83c2-f15dd1770c5e /home          btrfs   subvol=/@home,defaults,noatime,compress=zstd 0 0
/dev/mapper/luks-e83265a6-a0a0-41ad-83c2-f15dd1770c5e /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd 0 0
/dev/mapper/luks-e83265a6-a0a0-41ad-83c2-f15dd1770c5e /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd 0 0
/dev/mapper/luks-c09a9faf-b678-4976-a817-2cd84e0c58c5 swap           swap    defaults   0 0
1 Like

Looks like your luks partition didn’t get unlocked perhaps? Can you make sure your caps lock isn’t on and the password is getting put in correctly?

Password is correct, after entering the pw it reads “Slot 0 opened”, GRUB loads, starts Endeavouros and that’s when this error happens. If I put in the wrong PW, it doesn’t even load the usual GRUB menu.

Can we see the messages above the errors

Had to type them by hand, sorry for the delay:

running early hook [udev]
Starting systemd-udevd version 252.4-2-arch
running hook [udev]
Triggering uevents…
running hook [keymap]
Loading keymap…done.

That’s all there is before the “Waiting 10 seconds for device…” line

I see only this is legacy system or CSM install ?
First thing to try is to boot into rescue ISO (installer) and arch-chroot as shown on the bottom of the wiki for BTRFS and encryption… (have in mind that you do not have the esp fat32 partition)

When inside the chroot:

  1. update installed system pacman -Syu
  2. regenerate kernel images according to your install latest ISO used dracut molder install or changed Mkinitcpio: mkinitcpio -P
    Dracut: dracut-rebuild
  3. reinstall grub files: grub-install /dev/sda and regen grub.cfg: grub-mkconfig -o /boot/grub/grub.cfg
    logout the chroot and reboot into installed system (if lucky)

This worked, thank you very much! I couldn’t update the system because the chroot had no internet connection, even though the livesystem had, but it worked anyway. Thank you once again :+1:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.