Boot and reinstall issues

Regards, Two weeks ago I installed EndeavorOS and I had no problem, but a few days ago it started to put problems, the screen came out to choose OS but endeavor said that there was an error, then the grub screen no longer came out and it only loaded win 10, I have installed endeavorOS on a 240 gb ssd and win 10 on another 240 gb ssd, I tried to reinstall but it was but now at the end of the installation I get the following:


I’m new and I can’t find a solution, what can I do?

Currently does it boot into windows 10?

If windows 10 boots without problem

You are going to have to boot up on the live ISO and provide some hardware information. You may have to install inxi.

sudo pacman -S inxi

Then you can provide a link from this command.

inxi -Fxxxz --no-host | eos-sendlog

Would also like to see the output of this command.

sudo fdisk -l

sudo fdisk -l:
Disk /dev/sda: 223.58 GiB, 240065183744 bytes, 468877312 sectors
Disk model: WDC WDS240G2G0A-
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 54DC0041-B06B-4558-B54F-14A25F702A8A

Device Start End Sectors Size Type
/dev/sda1 2048 206847 204800 100M EFI System
/dev/sda2 206848 239615 32768 16M Microsoft reserved
/dev/sda3 239616 467823494 467583879 223G Microsoft basic data
/dev/sda4 467824640 468873215 1048576 512M Windows recovery environment

Disk /dev/sdb: 223.57 GiB, 240057409536 bytes, 468862128 sectors
Disk model: TEAM T253LE240G
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x533951a7

Device Boot Start End Sectors Size Id Type
/dev/sdb1 * 2048 450402085 450400038 214.8G 83 Linux
/dev/sdb2 450402086 468857024 18454939 8.8G 82 Linux swap / Solaris

Disk /dev/sdc: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: TOSHIBA DT01ACA0
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x801446d0

Device Boot Start End Sectors Size Id Type
/dev/sdc1 2048 430079999 430077952 205.1G 7 HPFS/NTFS/exFAT
/dev/sdc2 430080000 976771071 546691072 260.7G 7 HPFS/NTFS/exFAT

Disk /dev/loop0: 1.78 GiB, 1911021568 bytes, 3732464 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

but, the install inxi, says error in the mirror

Okay … no problem.
I just want to understand your disk layout here. Looks like Windows is installed in UEFI mode but llinux was installed in Bios mode. What is the other drive? /dev/sdc

Edit: Are there 3 drives?

I have two SSD drives, the / dev / sda is the one for windows, the / dev / sdb drive is for Linux and the / dev / sdc drive is a HDD hard drive

Yes, i have 3 drives

Okay so the installation on Windows is GPT and UEFI the other two drives are DOS. What is the hard drive for?

To install EndeavorOS I chose / dev / sdb, which even the first installation did not present problems, but two weeks later grub stopped working and only loads windows 10, when trying to reinstall I get the message that is in the photo

The HDD / dev / sdc disk, is only to save information

First make sure that secure boot and fast boot in UEFI Bios are turned off. There is also another feature in Windows 10 that is called fast startup that should also be disabled in Windows 10 as it uses hiberfile.
It may have installed the first time and i don’t know how it was installed but now it is installed on a DOS partition. It needs to be a GPT partition and UEFI. So i would say that you need to check the settings first in the UEFI Bios. Then when you reinstall you need to boot on the live ISO. Use gparted and create a new partion GPT on the drive that you are installing EndeavourOS to. This will erase all partitions on that drive. Not sure if you have files on it you need since you installed it? Then you can start the installer and use erase disc and select what you want. Make sure it say’s EFI at the top left and you have the correct drive when you proceed.

Edit: The other hard drive doesn’t matter.

ok thanks i will try according to the instructions, i will tell you the result

1 Like

recheck all option in your UEFI

SecureBoot off
Fast Boot off
No CSM
No Legacy
all disks on AHCI
No Optane/RST

you can check in terminal

inxi -Fxza
test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l

boot on UEFI[Legacy] will try to install in MBR…

2 Likes

Judging from the picture you posted, you are installing the bootloader for a Legacy/MBR install on /dev/sda which is GPT and not /dev/sdb. That is the reason of the failure.

I guess even if you would install the bootloader on /dev/sdb, you would end up with a mixed boot mode UEFI-Legacy dualboot. system.

1 Like

Not sure how it was installed the first time that it worked? But, if it’s installed in Bios with dual boot and UEFI is the other OS installation it’s bound to be a problem.

1 Like

Yeah, we are in the dark about that.

Sounds like a classic recipe for a bit of trouble. At any rate the advice given by you and @Stephane should resolve OP’s issue.

Good afternoon, thanks for the instructions, after trying to reinstall and the boot did not work, I realized that the disk where it was installed in some part of the process was left with an MBR partition, I erase the disk and pass it to GPT and it was installed correctly and I start in dual boot, but in the case of the recommendations if I could deactivate fast boot, not CSM and disks in AHCI, but my ASUS board does not allow Secureboot to be deactivated, and now a few days after the installation it has started to give dual boot problems,

Not up on this personally, but I understand that rEFInd can handle secure boot if necessary - might want to research that a bit.
https://www.rodsbooks.com/refind/

What ASUS board refuses to disable secure boot? I’ve used a lot of them (3 in action currently) and have never seen that…

It is an ASUS PRIME B250-A motherboard, check all the setup and the part where it says secureboot cannot be selected, it only informs that it is activated