Bluez 5.72? Is this suppose to work?

I couldn’t get my Sony headphones to work with the latest ‘bluez’ file 5.72 and had to downgrade to 5.64.2. I read a post that was two years old about this problem with connections using bluez. Is there other files that need to be installed to use this latest version? I re-installed my system the other day to get Timeshift and snapper to work (left ext4 for btrfs). This is when I couldn’t get my bluetooth to work for my headphones. I read the tutorial on installing bluetooth and followed the instructions but to no avail did it recognize the headphones until I read this post from two years back and downgraded to 5.64.2 from 5.72. What am I missing here? The headphones now work with the old bluez. The newer files suppose to work i.e. (problems fixed)?

Rich;) confused.

What tutorial did you read?
This is what you should have read

I read your link and did exactly what it said. . . . this is the tutorial I used initially but it failed to get and recognize my Sony bluetooth headphones.

This is the post that fixed my problem with bluetooth. . . (2 years old) I believe.
It was from Joekamprad ‘Der Doktor’.

[ Downgraded bluez packages to 5.64-2 causing failed BT to startup.

[fixed] Important notifications Mar '22 - …written in PHP. sudo downgrade bluez bluez-utils and restarting the service sudo systemctl restart bluetooth.service should be a workaround currently, if you are getting this issue. ](Update to bluez packages 5.64-2 causing failed BT startup [fixed])

5.72 did not work but going to 5.64-2 did as I downgraded to it and then my headphones began working and was recognized by bluez apt in ‘Hardware’. . . bluetooth.

Bluez in Octopi is in the ‘red’


BT is and never was flawless working:

But in case the best is to remove devices that are paried and rescan repair them over cli
sudo bluetoothctl

scan on
pair *device-UUID*
connect  *device-UUID*

Could be i your case something changed on BT stack in latest bluez so downgrading works with old setup used…


I recently had some issues with bluez throwing out error about org.bluez.obex.service , installing bluez-obex fixed it.

This is not normally an installed package.

I’ve only ever had Bluetooth issues when on the latest kernel. Same with wifi. It’s one of the reasons why if you can run the LTS kernel, you absolutely should be. It’s significantly less likely to be a problem on LTS.

I know, I just said it solved my problem, so it’s worth trying.

I just pointed that out because bluez-obex has to do with something entirely different than connecting headphones. It’s a protocol for sending files via bluetooth.

1 Like

that’s true in many ways. and should be the first thing to try before downgrading anything on archbased.
And in many cases on common usage you will be fine using LTS Kernel, you do not have to keep yourself on the edge to hard :wink:

@Stefax2001 :

extra/bluez-obex 5.72-2 (285.6 KiB 869.8 KiB) 
    Object Exchange daemon for sharing content

this will be only a solution if you need obex file transfer … Bluetooth Audio is something different… and also pairing.

1 Like