Bluetooth USB dongle using wrong module

I have a Realtek BH519A dongle which I have spent days trying to get to work properly. When I plug in this dongle, it shows up, but is using the wrong btusb module instead of the intended rtk_btusb. This would be fine but the connection using the wrong module is abysmal and my headphones stutter constantly in direct range (<3ft) and blueman shows the link quality as 10%. I’ve tried to manually unbind btusbt and bind rtk_btusb but trying to bind the rtk_btusb module doesn’t work. I unbind the btusb module with :
sudo sh -c "echo 1-11:1.0 > /sys/bus/usb/drivers/btusb/unbind"
where 1-11:1.0 is the usb device id of the dongle. It now has no driver bound to it shown from usb-devices. Then when I try
sudo sh -c "echo -n 1-11:1.0 > /sys/bus/usb/drivers/rtk_btusb/bind"
there is an error :
sh: line 1: echo: write error: No such device
I’ve noticed that there is a symlink directory corresponding to 1-11:1.0 which exists in /sys/bus/usb/drivers/btusb when bound to it which disappears when unbound from btusb but does not appear at all in /sys/bus/usb/drivers/rtk_btusb, which is why I’m guessing the error shows up. I just want to get my dongle to work with the right drivers and I’ve been trying for weeks with no progress. Any help is immensely appreciated.

Have you tried the more standard modprobe -r btusb; modprobe rtk_btusb ?

Yeah that didn’t work either which I tried initially.

Oh, right, it looks like you’ve already asked about this on the Arch forum:

That also contains more details about what you’ve tried, and that other people are having the same issue with other distros.

I’d complain to Realtek, or return the adapter and get one that actually works with Linux.

Or, given that you say that

and yet

could the issue possibly lie with your headphones?

I’ve tried zen, arch, and LTS kernels all of which have the same issue. I also tried hopping from Arch to Endeavouros thinking that maybe my Arch install was buggy as you could see from my previous post.

could the issue possibly lie with your headphones?

I’ve tested the headphones independently with my phone and they were fine even at long ranges. The success of the BH519A dongle seems mixed across distros but I saw a comment on the aur page for rtl8761b-fw claiming it worked with their exact same dongle. I have a few days left till the return deadline so I wanted to try whatever else possible to get it to work but if not I guess I could return it.

With kernel 5.11.15, yes.

You might want to revert any and all manual configuration changes you’ve made, then stick to the AUR package. If it doesn’t work with kernel 5.12 then try 5.10.

If it still doesn’t work then complain to the manufacturer.

The lts kernel I used was 5.10 which also didn’t work. My inital testing was on a 5.11 kernel prior to the 5.12 kernel update. I thought I narrowed the issue down to the USB symlinks but guess not. I will reach out to Realtek soon.