Bluetooth suddenly "dead"

Well, yesterday my bluetooth worked on kernel 6.0, today it just won’t start at all at the same kernel.

sudo systemctl enable bluetooth


sudo systemctl enable bluetooth.service

have no effect.

systemctl status bluetooth
○ bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: disabled)
     Active: inactive (dead)
       Docs: man:bluetoothd(8)

Trying to connect to bluetooth seems to take forever. At least it hasn’t connected while writing this post, giving my daughter breakfast, having her finish, and me turning on the TV.

Waiting to connect to bluetoothd...

I have no idea why this is happening. I did try out rEFINd yesterday, but wasn’t really fond of it so I uninstalled it as described in their documentation (delete refind folder in /boot/efi/EFI/refind).

I am yet to check if this works on lts kernel, but like I said, bluetooth worked fine on the newest kernel yesterday (literarly been 9 hours now). I will report back after a reboot, and on lts-kernel.

inxi -Z

  Host: ProX15 Kernel: 6.0.2-arch1-1 arch: x86_64 bits: 64 Desktop: GNOME
    v: 42.5 Distro: EndeavourOS
  Type: Laptop System: SLIMBOOK product: PROX-AMD5 v: Standard
    serial: <superuser required>
  Mobo: SLIMBOOK model: SLIMBOOK v: Standard serial: <superuser required>
    UEFI: American Megatrends LLC. v: N.1.06GRU06 date: 05/25/2022
  ID-1: BAT0 charge: 50.4 Wh (55.0%) condition: 91.6/91.6 Wh (100.0%)
  Info: 8-core model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 1456 min/max: 1400/4370 cores: 1: 1800 2: 1397 3: 1397
    4: 1400 5: 1671 6: 1400 7: 1561 8: 1400 9: 1400 10: 1400 11: 1397 12: 1400
    13: 1477 14: 1400 15: 1397 16: 1400
  Device-1: AMD Lucienne driver: amdgpu v: kernel
  Display: wayland server: X.Org v: 22.1.4 with: Xwayland v: 22.1.4
    compositor: gnome-shell driver: gpu: amdgpu resolution: 1920x1080~60Hz
  OpenGL: renderer: RENOIR (renoir LLVM 14.0.6 DRM 3.48 6.0.2-arch1-1) v: 4.6
    Mesa 22.2.1
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.0.2-arch1-1 running: yes
  Sound Server-1: PipeWire v: 0.3.59 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8168
  IF: enp1s0 state: down mac: b0:25:aa:4e:4c:5b
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlan0 state: up mac: 14:85:7f:0a:6e:73
  IF-ID-1: virbr0 state: down mac: 52:54:00:95:1b:d2
  Local Storage: total: 465.76 GiB used: 100.18 GiB (21.5%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT500P2SSD8 size: 465.76 GiB
  ID-1: / size: 465.46 GiB used: 100.18 GiB (21.5%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 912 KiB (0.3%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 465.46 GiB used: 100.18 GiB (21.5%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-4: /var/log size: 465.46 GiB used: 100.18 GiB (21.5%) fs: btrfs
    dev: /dev/nvme0n1p2
  Alert: No swap data was found.
  System Temperatures: cpu: 41.8 C mobo: N/A gpu: amdgpu temp: 39.0 C
  Fan Speeds (RPM): N/A
  Processes: 384 Uptime: 34m Memory: 15.02 GiB used: 4.94 GiB (32.9%)
  Shell: Bash inxi: 3.3.22

This took surprisingly long time, usually this takes few seconds to spit out. This time it was over a minute.

System is slow and not as it has been for the last two months.

OK, seems like something on kernel 6.0 is having this effect.
System is much snappier and the bluetooth works on lts.

Anyway, I feel like this thread is a waste of space…

Actual solution
Go through the maintenance tutorial and clean cache and remove orphans A Complete Idiot's Guide To Endeavour OS Maintenance / Update / Upgrade

Rebooted after that into rolling kernel, and bluetooth works like a charm… system no longer sluggish. Much better.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.