Bluetooth reconnecting problem

I’v recently installed latest KDE Plasma and every now and then (approximately 30 min) bluetooth seems to turn off and on again. While that Bluetoothctl shows: [CHG] Device B0:F1:A3:76:46:BB Connected: no [DEL] Transport /org/bluez/hci0/dev_B0_F1_A3_76_46_BB/sep2/fd0 [DEL] Endpoint /org/bluez/hci0/dev_B0_F1_A3_76_46_BB/sep1 [DEL] Endpoint /org/bluez/hci0/dev_B0_F1_A3_76_46_BB/sep2 [CHG] Device B0:F1:A3:76:46:BB Connected: yes
I’ve tried to reinstall or downgrade bluez, bluez-utils, bluedevil but it keeps reconnecting. When I tried to pair and trust device via console it worked at first, but failed to connect after reboot. What can I do?

give some hardware details:
inxi -Fxxc0z | eos-sendlog

  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-2:2 chip-ID: 1358:c123
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends

is this a USB dongle or integrated into the notebook? (Laptop System: HUAWEI product: HLY-WX9XX v: M1010)

Could be one inside the Network chipset … the often have issues by interfering with wifi usage… if possible you could check if with wifi disabled it works…

Yes, it’s integrated to my laptop. I’ve tried to turn off wifi (and my wireless mouse), but it keeps disconnecting over time

Ximierr, are you running TLP? Could it be a USB auto suspend problem?

You can blacklist or disable the auto suspend for Bluetooth either using tlp or tlpui

No, i have power-profiles-daemon preinstalled on my system.

hei nice to see you again @Strontium :enos:

And good point, in cases it can be TLP or the USB setting themself not working nicely with devices… and special in these cases where internal device is connected via USB connector…

you can try that in grub “linux” kernel line:


by pressing e in grub boot menu and add it at the end of the “linux” line and boot with it (press F10 or [Ctrl+X] )

or this for Bluetooth btusb

When i booted with first — nothing changed. When i booted with second (which took 3 reboots, just to load in the system; screenshots attached) — wifi and the mouse stoped working
When I tried to reboot again it showed this
After I turned it off manualy (for the fifth time :joy:) everything as it was, but mouse isn’t working

sure you added the option at the right place? and I would try LTS kernel to boot on could be also issue with kernel …

I’ve typed these commands as you suggested (in grub, after linux). Wireless connection to mouse isn’t working, but Bluetooth is stable :flushed: P.S. Nope - magic doesn’t happen. is still reconnects
P.S.S. next reboot
P.S.S.S. it fixed after another reboot



P.S. Problem solved after switching from pipiwire to pulseaudio (instruction in the endeavouros wiki)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.