Bluetooth not working with rtl8822ce and kernel 5.9.1

Since I’ve updated my laptop from kernel 5.8 to 5.9,1. This issue persists from kernel 5.9.1 to 5.9.6.

[santi@santiago-hplaptop15seq0xxx ~]$ inxi -Fxxc0z --no-host
System:    Kernel: 5.9.6-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 wm: kwin_x11 
           dm: SDDM Distro: EndeavourOS 
Machine:   Type: Laptop System: HP product: HP Laptop 15s-eq0xxx v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: HP model: 86FD v: 99.36 serial: <filter> UEFI: AMI v: F.17 date: 04/13/2020 
Battery:   ID-1: BAT0 charge: 28.7 Wh condition: 41.4/41.4 Wh (100%) volts: 11.5/11.3 model: Hewlett-Packard Primary 
           serial: N/A status: Discharging 
CPU:       Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen+ rev: 1 
           L2 cache: 2048 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33551 
           Speed: 1222 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1230 2: 1229 3: 1277 4: 1260 5: 1230 
           6: 1283 7: 1222 8: 1222 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 04:00.0 
           chip ID: 1002:15d8 
           Device-2: Luxvisions Innotech Limited type: USB driver: uvcvideo bus ID: 3-1.2:3 chip ID: 30c9:0013 
           Display: x11 server: 1.20.9 compositor: kwin_x11 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa 
           resolution: <xdpyinfo missing> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus ID: 04:00.1 chip ID: 1002:15de 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard 
           driver: N/A bus ID: 04:00.5 chip ID: 1022:15e2 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 04:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.9.6-arch1-1 
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtw_8822ce 
           v: N/A port: f000 bus ID: 02:00.0 chip ID: 10ec:c822 
           IF: wlan0 state: up mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 251.83 GiB (52.8%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000H1 size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> 
Partition: ID-1: / size: 29.40 GiB used: 17.73 GiB (60.3%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /home size: 434.49 GiB used: 234.09 GiB (53.9%) fs: ext4 dev: /dev/nvme0n1p4 
Swap:      ID-1: swap-1 type: partition size: 4.00 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A gpu: amdgpu temp: 44.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 244 Uptime: 34m Memory: 9.71 GiB used: 1.77 GiB (18.3%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           clang: 10.0.1 Packages: 1278 pacman: 1273 flatpak: 5 Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.08

Seems to be a regression with 5.9:

linux-lts will work until it is fixed in 5.9.

1 Like

Welcome aboard!

Thanks for your answer. I did this, I change to lts 5.4 it works at the beginning but then the system hang in boot with a black screen. It’s some weird because it happens when I reboot the system twice

For some of us for whatever reason adding secondary kernels just does not work. zen1 will not boot. Then to top that off it’s at the top of the list of kernels to boot when it was not set as default, so I end up mousing down to arch1 on the Grub menu. I have not tried the LTS yet.

1 Like

Thanks. I’d been using Debian testing a lot of years but when I bought my new laptops I couldn’t install it on one with nvidiq-hybrid. I had to change to kde neon although I don’t like Ubuntu. I’d like to try with archlinux and found Endeavouros what I have like very much

Welcome to the community :beers:

may nvidia driver installed? as this will need the lts version of nvidia-lts also and the kernel headers (linux-lts-headers)

Probably not:

Sorry. I have two laptops because my daughters. One is an Hp with an Intel 7 8th generation an Nvidia, in this I found that better system to use Nividia hybrid is Kde Neon. Another one is an AMD Ryzen with AMD Radeon Graphics, this is the one in which I’ve installed Endeavouros with Plasma Kde. In this one all works well and smoothly except the Bluetooth which stop with kernel 5.9 upgrade

issue verified on telegram :wink:

i see:
there is already a driver at AUR also:

ha ha now i can see, i do edit formatting on first post to use code tags…

1 Like

user on telegram tried that one and it do not solve the issue for latest kernel

1 Like

Has anyone bisected yet? If it for sure works on latest 5.8 point release I could bisect if I had a tester as I don’t have the devices in question

Have you tried the rtw88-dkms-git? This has support for rtl8822ce and latest realtek.


Think the post before mine says its not working atm

It’s a different package. This has the latest realtek files.

rtw88-dkms-git doesn’t fix bluetooth detection.
The issue is one patch away from being fixed, yet that patch has not been merged into the 5.9 source tree. More info in this Arch Linux forum post.

1 Like

I think this is set up to be fixed in linux-zen soon, damentz has included it in linux-lqx already.

Today I’ve updated my kernel to 5.9.9-arch1-1 and the issue persist.
[santi@santiago-hplaptop15seq0xxx ~]$ uname -r
[santi@santiago-hplaptop15seq0xxx ~]$ bluetoothctl
Agent registered
[bluetooth]# power on
No default controller available