Bluetooth not working on hp laptop

Screenshot from 2021-07-05 21-18-10
no devices show up
healp ‘-’

wiki your friend :blush: :innocent:

2 Likes

thanks mate

1 Like

Screenshot from 2021-07-05 21-57-57
the connection button doesnt stay onn can you help?

Look in the journal what happens while connecting your realme Buds Q.
User something like journalctl -b -0 -n20.
This gives you the latest 20 lines. Please post those lines here.

Jul 05 23:20:05 vishesh-hp241g1 discord.desktop[4698]: [Modules] Module installed file path: /home/vishesh/.config/discord/0.0.15/modules/installed.json
Jul 05 23:20:05 vishesh-hp241g1 discord.desktop[4698]: [Modules] Module download path: /home/vishesh/.config/discord/0.0.15/modules/pending
Jul 05 23:20:09 vishesh-hp241g1 discord.desktop[4698]: [Modules] No updates to install
Jul 05 23:20:09 vishesh-hp241g1 discord.desktop[4698]: [Modules] Checking for host updates.
Jul 05 23:20:10 vishesh-hp241g1 discord.desktop[4698]: [Modules] Host is up to date.
Jul 05 23:20:10 vishesh-hp241g1 discord.desktop[4698]: [Modules] Checking for module updates at https://discord.com/api/modules/stable/versions.json
Jul 05 23:20:10 vishesh-hp241g1 discord.desktop[4698]: [Modules] No module updates available.
Jul 05 23:20:33 vishesh-hp241g1 systemd[1226]: Started Application launched by gnome-shell.
Jul 05 23:20:34 vishesh-hp241g1 /usr/lib/gdm-x-session[1242]: (II) RADEON(0): EDID vendor “CMN”, prod id 5281
Jul 05 23:20:34 vishesh-hp241g1 /usr/lib/gdm-x-session[1242]: (II) RADEON(0): Printing DDC gathered Modelines:
Jul 05 23:20:34 vishesh-hp241g1 /usr/lib/gdm-x-session[1242]: (II) RADEON(0): Modeline "1366x768"x0.0 76.42 1366 1434 1479 1592 768 772 779 800 +hsync -vsync (48.0>
Jul 05 23:20:34 vishesh-hp241g1 /usr/lib/gdm-x-session[1242]: (II) RADEON(0): Modeline "1366x768"x0.0 50.95 1366 1434 1479 1592 768 772 779 800 +hsync -vsync (32.0>
Jul 05 23:20:42 vishesh-hp241g1 bluetoothd[504]: profiles/audio/avdtp.c:avdtp_connect_cb() connect to 6C:CE:44:7A:75:19: Host is down (112)
Jul 05 23:20:45 vishesh-hp241g1 systemd[1226]: Started Application launched by gnome-shell.
Jul 05 23:20:45 vishesh-hp241g1 dbus-daemon[1256]: [session uid=1000 pid=1256] Activating via systemd: service name=‘org.gnome.Terminal’ unit='gnome-terminal-server.se>
Jul 05 23:20:45 vishesh-hp241g1 systemd[1226]: Starting GNOME Terminal Server…
Jul 05 23:20:45 vishesh-hp241g1 dbus-daemon[1256]: [session uid=1000 pid=1256] Successfully activated service ‘org.gnome.Terminal’
Jul 05 23:20:45 vishesh-hp241g1 systemd[1226]: Started GNOME Terminal Server.
Jul 05 23:20:45 vishesh-hp241g1 systemd[1226]: Started VTE child process 5069 launched by gnome-terminal-server process 5050.
Jul 05 23:20:45 vishesh-hp241g1 systemd[1226]: app-gnome-org.gnome.Terminal-5046.scope: Deactivated successfully.

sudo rfkill list 
  • metal or vm ?

EDit
just idea ( check device in pairing/discovery mode)

There is only this one line that is related to bluetooth. To me this line is not that specific.
Please check the arch wiki: https://wiki.archlinux.org/title/Bluetooth especially the troubleshooting section. May be you can find some hints why it is not connecting.

2 Likes

archwiki suggests to pair/trus/connect headset/headphones with bluetoothctl as root the first time if it fails.
so remove the device close bluetooth settings and run this from terminal:
sudo bluetoothctl
scan on
pair uuid-of-headset
trust uuid-of-headset
connect uuid-of-headset

2021-07-06_00-30
@vishesh

1 Like

[vishesh@vishesh-hp241g1 ~]$ sudo rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

this doent work

[bluetooth]# trust 6C:CE:44:7A:75:19
Changing 6C:CE:44:7A:75:19 trust succeeded
[bluetooth]# connect 6C:CE:44:7A:75:19
Attempting to connect to 6C:CE:44:7A:75:19
Failed to connect: org.bluez.Error.Failed
[bluetooth]#

Can you also post the output of inxi -Fxxxza --no-host
Format the copied and pasted text from a terminal by placing three ``` before and after the output so it looks like:

copied text
[vishesh@vishesh-hp241g1 ~]$ inxi -Fxxxza --no-host
System:
  Kernel: 5.12.14-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux 
  root=UUID=4f10ee29-8d80-4d05-8d75-6c2ef5bdb993 rw quiet splash 
  usbcore.autosuspend=-1 
  Desktop: GNOME 40.2 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: EndeavourOS base: Arch Linux 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP 241 G1 
  v: 0985100000400010060670081 serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: Hewlett-Packard model: 8072 v: KBC Version 70.07 serial: <filter> 
  UEFI: Insyde v: F.34 date: 09/01/2015 
Battery:
  ID-1: BAT0 charge: 25.1 Wh (100.0%) condition: 25.1/25.1 Wh (100.0%) 
  volts: 16.7 min: 14.8 model: Hewlett-Packard Primary type: Li-ion 
  serial: <filter> status: Full 
CPU:
  Info: Quad Core model: AMD A4 PRO-3340B with Radeon HD Graphics bits: 64 
  type: MCP arch: Jaguar family: 16 (22) model-id: N/A stepping: 1 
  microcode: 700010F cache: L2: 2 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 17573 
  Speed: 2194 MHz min/max: 1100/2200 MHz Core speeds (MHz): 1: 2194 2: 2171 
  3: 1644 4: 2196 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Kabini [Radeon HD 8240 / R3 Series] vendor: Hewlett-Packard 
  driver: radeon v: kernel alternate: amdgpu bus-ID: 00:01.0 
  chip-ID: 1002:9838 class-ID: 0300 
  Device-2: Chicony HP Truevision HD type: USB driver: uvcvideo 
  bus-ID: 1-4:2 chip-ID: 04f2:b509 class-ID: 0e02 
  Display: x11 server: X.org 1.20.11 compositor: gnome-shell driver: 
  loaded: ati,radeon unloaded: fbdev,modesetting,vesa 
  resolution: <missing: xdpyinfo> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840 
  class-ID: 0403 
  Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel 
  v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.14-arch1-1 running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.31 running: no 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8168 v: 8.049.02-NAPI modules: r8169 
  port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 2000 
  bus-ID: 05:00.0 chip-ID: 10ec:b723 class-ID: 0280 
  IF: wlan0 state: up mac: <filter> 
  IF-ID-1: anbox0 state: down mac: <filter> 
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus-ID: 5-1:2 chip-ID: 0bda:b001 class-ID: e001 serial: <filter> 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:
  Local Storage: total: 465.76 GiB used: 15.89 GiB (3.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS545050A7E680 
  size: 465.76 GiB block-size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: A350 scheme: GPT 
Partition:
  ID-1: / raw-size: 465.26 GiB size: 456.88 GiB (98.20%) 
  used: 15.89 GiB (3.5%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) 
  used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 65.5 C mobo: N/A gpu: radeon temp: 68.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 213 Uptime: 5h 00m wakeups: 7 Memory: 3.31 GiB 
  used: 2.96 GiB (89.4%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 11.1.0 Packages: 978 pacman: 974 lib: 240 snap: 4 Shell: Bash 
  v: 5.1.8 running-in: gnome-terminal inxi: 3.3.03 

here

Your BIOS is 6 years old. You might want to look at updating that. You could also try the LTS kenel and see if that helps. To install the LTS Kernel in a terminal type:
sudo pacman -S linux-lts linux-lts-headers
Then update grub:
sudo grub-mkconfig -o /boot/grub/grub.cfg
and reboot.
Select the LTS kernel from the grub screen.

i would also look into what this is trying to tell you.

You may also find this thread interesting…seems some older hardware has issues with Arch linux.
https://bbs.archlinux.org/viewtopic.php?id=263040

1 Like

it says this

‘’’==> Image generation successful
(4/4) Update grub after installing or removing a kernel or microcode.
/etc/default/grub: line 6: usbcore.autosuspend=-1: command not found
error: command failed to execute correctly’’’

i dont remeber what was there before i changed it

You have to long press each ear bud for 5 seconds to put them in pairing mode. Press both at the same time and hold for 5 seconds. They should pair properly after that and connect if you go through the proper procedure. It’s not Bluetooth not working on the laptop. It’s the earbuds not connecting properly and staying connected.

1 Like

had trouble with gnome before @ bluetooth headset, now i use blueman ( i no little about bluetooth ) where gnome settings fail me on bluetooth ! blueman never let me down …

try that as your computer bluetooth works

sudo pacman -S blueman ( worth try )

Screenshot from 2021-07-07 20-06-14

i am tired of trying at this point

i have tried that too

i saw there are no updated