Bluetooth not working after installing bluez-plugins and downgrading it

Hello everyone,

I find myself with a rare issue I cannot see how to fix. I tried to pair my PS3 controller through bluetooth like I did on my steam deck with no issue but I was not working.

I was not able to see my controller but I was able to connect to other devices.
Tried using bluetoothctl but I could not see or pair it.

After finding some forum posts about it one was to install bluez bluez-utils bluez-plugins so I did it but I was not working either.

Then I downgraded those packages to old versions but then bluetoothctl stopped working giving me this message:

No default controller available

Tried to fix it by re-installing the latest versions without luck.

Now I don’t know what to do, I can see my device but I cannot make it work either through bluetoothctl or KDE gui.

rfkill list it as unblocked

$ rfkill
0 bluetooth hci0 unblocked unblocked
1 wlan phy0 unblocked unblocked

$ lsmod | grep bt
btusb 86016 0
btrtl 32768 1 btusb
btintel 57344 1 btusb
btbcm 24576 1 btusb
btmtk 12288 1 btusb
bluetooth 1114112 15 btrtl,btmtk,btintel,btbcm,bnep,btusb

I followed the official guide about bluetooth, service is running and enabled but the message about no default controller remains.

Not sure if this would work in your case, as I run Gnome, but since Gnome recently messed up bluetooth on my hardware (across several distros), here’s the solution I found. In my case my peripherals are recognized but they won’t connect. What to do?

I installed blueman and it worked great to recognize and connect my bluetooth perifpherals. Then I deleted blueman. From then on my bluetooth on Gnome has worked normally.

Hi, I tried blueman too but didn’t worked either.

Now after some hours it works magically, I had to boot windows and after that now it works.

I don’t know why, I didn’t changed anything.

Weird or not, nice that it worked. :sunglasses: