Bluetooth not recognizing xbox controllers

Hey all, lately I’ve been having trouble getting my xbox controllers to connect via bluetooth. So far I’ve tried using bluetoothctl both with and without xpadneo but have had no luck. For some reason when I begin pairing on the controller it fails to even show up in bluetoothctl and the gui bluetooth scanner for plasma. The annoying thing is that I can get windows on the same machine to see and connect to them just fine. Any help is appreciated and I’d be happy to give any info needed.

Edit: forgot to mention that I can verify bluetooth is working in general on endeavour as I was able to see and connect to some skullcandy headphones

Edit 2: To specify, previously I have been able to connect an xbox controller but one day it wouldnt connect so I tried removing it to pair it again but it never showed back up in the pairing menu. Since then I have bought a new controller but it also doesnt show up.

Hmm. . . I will see what else I can find, but xpadneo definitely works her on my elite series 2. . .

I can’t imagine why kde would matter work.

Do you have secure boot on? xpadneo 100% doesn’t work with secureboot.

Turned secureboot off and no luck.

And you rebuilt the package? It has a kernel element, so it’s part of the kernel and will likely need to be rebuilt with the package and system restart prior to working as well. . .

Note - please post complete input/output when you do this so we can see everything works and doesn’t fail.

Do you also meet the prerequisites?


Make sure you have installed dkms, linux headers and a bluetooth implementation (e.g. bluez) and their dependencies.

Kernel maintainers should also include the uhid module (CONFIG_UHID) because otherwise Bluetooth LE devices (all models with firmware 5.x or higher) cannot create the HID input device which is handled in user-space by the bluez daemon.

  • On Arch and Arch-based distros (like EndeavourOS), try sudo pacman -S dkms linux-headers bluez bluez-utils
1 Like

Rebuilt what package and how would I go about rebuilding it?

Apologies I’m new to the forum, how should I post input/output?

Rebuild it as you would build any AUR package (usually with yay or paru)


I dont know what package you’re wanting me to rebuild nor how to do that.

yay *package*

And cleanbuild.

Ok, but what package?

Did a test with my skullcandy earbuds to see if maybe there was a bug with bluetooth when forgetting a device. My theory was when you would forget a device it would just refuse to ever see it again, not the case. After forgetting the earbuds they showed up again when scanning for devices to add. My apologies if my replies arent the nicest, Im tired and just want this stupid bluetooth problem to disappear.

It would be the xpadneo package - but to be perfectly honest with you - my controller shows up even w/o the package - the full functionality just isn’t there without it.

Bluetooth is bluetooth - so I can connect to my series elite without xpadneo.

If you literally cannot see it at all, I’d imagine maybe it’s using a bluetooth config too new for the hardware in your computer, for instance bluetooth 5 vs 4 or something. Or there’s something wrong with the bluetooth in your control, or you’re not putting it in pairing mode properly.

Does it work plugged into usb? (you need the xpad package installed)

The controller I used previously originally connected without xpadneo installed so I don’t think adding xpadneo is doing much for me. The thing is that the controller was connecting just fine but one day just up and stopped connecting. The only thing that I think could have happened is some update to some package broke something so it doesn’t appear anymore. Like I said the controllers work cause windows connects just fine and Bluetooth on endeavour works cause my headphones can pair and connect. Also yes the controllers do work over USB. Honestly in about a months time I wouldnt be using the controllers with Bluetooth cause I’m moving up to college and for some odd reason Bluetooth up there is really bad even on windows, never found out why. It’d just be nice to know Bluetooth is working with the controllers.

xpadneo is required if you want to use an xbox 1/series controller correctly via bluetooth. It’s not optional, and it will not work correctly without it.

I didn’t realize that they were working and now they are not. Since you havne’t actually shown any outputs that you rebuilt xpadneo or fullfilled the pre-req’s I’m assuming you have, but that could still be an issue. It’s tied to the kernel/dkms though - updates do break that, it’s not horribly uncommon, as is bluetooth. BUT - that being said if other stuf is working, and only that is not sounds like it’s probably the controller.

You still haven’t rebuilt the package that I can tell which I asked for quite a while ago. But if it literally doesn’t show up and it used to, but other bluetooth stuff is working - that SCREAMS hardware issue on the controller’s part.