Bluetooth is diabled and won't enable

Bluetooth is not seeming to work. I’ve tried enabling, starting, and restarting bluetooth but it still does not work. If I press the arrow at the bottom right of my screen to pull up “status and notifications” when I click on bluetooth it seems to work at first, but it doesn’t actually detect any devices. If I pull up bluetooth in settings it just says “bluetooth disabled” and when I press enable nothing happens.

Did you look there, maybe there’s some info

I tried that, and it worked when I first got endeavourOS, but at one point it just started saying bluetooth disabled and none of that stuff works. To me it seems to be a visual glitch of sorts but I don’t know.

did you try with the console and like bluetoothctl commands or else
I remember aving issues like that at one point but can’t remember how I managed it…

im trying but none of this seems to work.

It would be more constructive to find out why the bluetooth service failed in the first place.

$ journalctl -u bluetooth.service | eos-sendlog
$ systemctl status bluetooth.service

Is Bluetooth correctly installed and activated?

sudo systemctl enable bluetooth.service
sudo systemctl start bluetooth.service

that’s what I understood

After updating to Plasma 6. my bluetooth was disabled for some reason.

Sharing the output of what @anthony93 suggested in post 6 will help with better identifying the issue to hand.

In addition to the above, sharing the output of inxi --bluetooth might also help.

@Balder In this instance, I might recommend the following small change. Otherwise a reboot is needed.

sudo systemctl enable --now bluetooth.service

@duckOSisme Can you confirm that all of the bluetooth packages are installed for your DE? Are you trying to do this via terminal or GUI?

1 Like

im doing this via terminal and all bluteooth packages are installed

1 Like

It’s Bluetooth still not working?

Can you please share the output from systemctl status bluetooth.service?

I should have asked this before. It’s your Bluetooth part of your WiFi card? If yes, is your WiFi card enabled? In some cases (not always) a Bluetooth/WiFi combo card will sometimes not work if the entire card is not enabled (for example if you use an Ethernet connection for Internet).

Can you please also share the output of

inxi --bluetooth

as well as

journalctl -u bluetooth.service

systemctl status bluetooth.service

This will help us better diagnose your problem.

According to all of that, bluetooth should be working.

In your system settings, what does the bluetooth look like? Is ‘Enabled’ toggled on? What about the configuration options (top right corner), what does that look like?

What about pacman -Ss bluetooth | grep installed?

By the way, copying the contents of your terminal and pasting them with three back ticks (```) before and three after the output, makes it much easier for others to read.