Bluetooth Headset stops working when I pause video for 10-20 seconds

It works fine but when it gets idle even for few seconds it stops working even though it is connected to my laptop. I have to disconnect and reconnect it every-time. which is getting annoying.

I found this on arch wiki

To disable loading of the module-suspend-on-idle module, comment out the following line in the configuration file in use (~/.config/pulse/ or /etc/pulse/ ):

but there is no file inside pulse directory, nor in /etc neither in .config

their is one file client.conf

# This file is part of PulseAudio.
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# General Public License for more details.
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <>.

## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; default-sink =
; default-source =
; default-server =
; default-dbus-server =

autospawn = no
; autospawn = yes
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; auto-connect-localhost = no
; auto-connect-display = no

how should i fix this

PulseAudio? I suspect you’re not even using PulseAudio. Try to change the configuration in wireplumber instead. Try these first:

Also, it would be great if you can post the output of inxi -A

Wireplumber’s documentation explains all the configuration options:


thanks, now its fine

When I was searching all the results were only for pulseaudio, and I did’t knew what I was using

here the output of inxi -A

  Device-1: Intel Comet Lake PCH cAVS driver: snd_hda_intel
  Device-2: NVIDIA driver: snd_hda_intel
  API: ALSA v: k6.4.11-arch2-1 status: kernel-api
  Server-1: PipeWire v: 0.3.77 status: active

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.