Bluetooth headphones not connecting

I added Bluetooth support using the below article and all seems to be installed correctly, but when I turn on the headphone, hold the button for the ready to pair message, press connect button in systray applet while still holding down the button on the headphones I get the below.

Bluedio
Connect to the device failed

If I try it from Bluetooth in System Settings I get.

Host is down

Type: Headset
Address: 16:03:24:11:15:57
Adapter: TheMothership #1
Name Bluedio
Trusted checked

How to Set up Bluetooth in Arch Linux.pdf (580.1 KB)

Ideas on how to fix this would be greatly appreciated. Thanks

[alienprober@TheMotrhership ~]$ inxi -Fxxxza
System:
  Kernel: 5.9.8-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux 
  root=UUID=128d1d7c-1028-4416-b91d-882b6c7c7d2b rw rootflags=subvol=@ quiet 
  loglevel=3 nowatchdog 
  Desktop: KDE Plasma 5.20.3 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: EndeavourOS 
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx 
  serial: <filter> UEFI: American Megatrends v: 3103 date: 06/17/2020 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard K360 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Discharging 
CPU:
  Info: Quad Core model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 
  type: MCP arch: Zen+ family: 17 (23) model-id: 18 (24) stepping: 1 
  microcode: 8108109 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 28757 
  Speed: 1325 MHz min/max: 1400/3600 MHz boost: enabled Core speeds (MHz): 
  1: 1298 2: 1632 3: 1272 4: 1434 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: eVga.com. 
  driver: nvidia v: 455.38 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:2187 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia 
  unloaded: fbdev,modesetting,vesa alternate: nouveau,nv display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 2560x1080 s-dpi: 97 s-size: 670x283mm (26.4x11.1") 
  s-diag: 727mm (28.6") 
  Monitor-1: HDMI-0 res: 2560x1080 hz: 60 dpi: 97 size: 673x284mm (26.5x11.2") 
  diag: 730mm (28.8") 
  OpenGL: renderer: GeForce GTX 1650 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38 
  direct render: Yes 
Audio:
  Device-1: NVIDIA TU116 High Definition Audio vendor: eVga.com. 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:1aeb 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 0a:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.9.8-arch1-1 
Network:
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel 
  port: d000 bus ID: 04:00.0 chip ID: 8086:1539 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 16.38 TiB used: 7.79 TiB (47.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 model: Viper M.2 VPN100 size: 238.47 GiB block size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  rev: ECFM22.6 scheme: GPT 
  ID-2: /dev/sda vendor: Western Digital model: WD10EARS-00Y5B1 size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> 
  rev: 0A80 scheme: GPT 
  ID-3: /dev/sdb vendor: Seagate model: ST3000DM001-1E6166 size: 2.73 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm 
  serial: <filter> rev: SC48 scheme: GPT 
  ID-4: /dev/sdc type: USB vendor: Seagate model: Expansion size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B serial: <filter> rev: 9300 
  scheme: GPT 
  ID-5: /dev/sdd type: USB vendor: MediaMax model: WL3000GSA6454 size: 3.41 TiB 
  block size: physical: 4096 B logical: 512 B rotation: 5400 rpm 
  serial: <filter> scheme: GPT 
  ID-6: /dev/sde type: USB vendor: Seagate model: Expansion Desk size: 7.28 TiB 
  block size: physical: 4096 B logical: 512 B serial: <filter> rev: 9401 
  scheme: GPT 
Partition:
  ID-1: / raw size: 237.99 GiB size: 237.99 GiB (100.00%) 
  used: 69.55 GiB (29.2%) fs: btrfs dev: /dev/nvme0n1p2 
  ID-2: /home raw size: 237.99 GiB size: 237.99 GiB (100.00%) 
  used: 69.55 GiB (29.2%) fs: btrfs dev: /dev/nvme0n1p2 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 40.2 C mobo: N/A gpu: nvidia temp: 43 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 336 Uptime: 3h 41m Memory: 15.62 GiB used: 3.94 GiB (25.2%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1500 pacman: 1449 
  lib: 364 flatpak: 44 snap: 7 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.08
1 Like

I do not know why but I always have problems with Bluetooth on EOS. Whatever I do, it does not work :confused:

Tested Manjaro just a few days ago. Worked immediately. On all distro I tested, I get BT to work. But not on EOS :frowning:

1 Like

Please post what you normally do and I’ll compare with the steps I’ve taken so far. Thanks

while still holding down the button on the headphones I get the below. —> this will power off the BT-Headset.
usually you press and hold the powerbutton on BT-Headset till it goes to pairing mode, then leave the button.
Now you BT-Tool should see the BT-Headset, you go forward to trust it, pair it, and then connecting to it.

In some cases for BT-Headset to get connected the first time it helps to use the bluetoothctl cli tool as root to pair trust and connect:
https://wiki.archlinux.org/index.php/Bluetooth_headset#Configuration_via_CLI

1 Like

I do not even remember what I did. EVERYTHING! :smiley:

I’ll try a little more. Should not be impossible to get on BT. A little harder apparently.

I follow this thread and see if I get any tips!

1 Like

@joekamprad thanks for the links and info. I’ll take a look at it in the morning and let you know what happened.

1 Like

as long as BT-Device itself is working without an issue on driver or firmware (can happen on wifi/bt chipsets and some crappy BT-devices hacked by producer to work on Windows…)
You should get BT-Headset working on EndeavourOS, but BT is crappy on itself… some devices have an issue if you connect a BT-Headset from another OS (Dualboot) and then come back to first OS where you have BT-headset connected before it fails to connect… mostly it helps to remove device from BT-Settings and repair e.t.c.

OK after literally trying everything I’m still not having any luck. Good thing is I was only trying top get it up on my system to test for my roommate, cause once the next EOS ISO drops I’m finally installing it for him and thought it would be nice for him to have his bluetooth available. I’ll try again on his machine once I’ve installed EOS and see what we get. Thanks guys for the info and advice, greatly appreciated.

Can you check this?

1 Like

OK thanks I didn’t see that.