Bluetooth: hci0: Malformed MSFT vendor event: 0x02

Hi all,
I can’t seem to get past the bluetooth error
“Bluetooth: hci0: Malformed MSFT vendor event: 0x02”

Here are my rough specs:
R5 5600
GTX 1060
16 gb ram

This computer is on a dual boot as well.

At first, I thought this was because my flash drive got corrupted (I had a few issues with it before), so I bought another flash drive and it still had the same issue.

I tried going to tty and used:
“sudo systemctl enable bluetooth”
“sudo systemctl enable —now bluetooth”

which both of them caused the boot screen to stop at:
“[ OK ] Started Accounts Service.”

I tried unplugging the bluetooth from my wifi card and that did the same thing. I then tried plugging the connector back in and got the original error code. I did a quick search online on that bluetooth error code and tried everyone else’s solutions, but it didn’t work for me. Got any ideas on how to fix this? I’m pretty new to this whole linux thing so please don’t mind me asking stupid questions.

1 Like

What is your hardware? Post the url

inxi -Faz | eos-sendlog

Does it show the bluetooth device

inxi -E

[quote="DHDK, post:1, topic:43074"]
I tried unplugging the bluetooth from my wifi card and that did the same thing. I then tried plugging the connector back in and got the original error code.

What about the WiFi? Is the bluetooth on the same card?

inxi -Na
1 Like

Here’s the URL:

Yeah, it does show the bluetooth device and the wifi as well
Yes, the bluetooth is on the same card.

I don’t think the error message is a problem. Does the device work? It shows the hardware and should work.

1 Like

I don’t think it is as well. The device works perfectly fine on windows so I’m assuming it would still work on linux as well

Hi you are resolved this problem? I have the same issue

Unfortunately, I have not. I’ve been just waiting around for someone knowledgeable to help me out. All I know so far is that:

  1. There’s no problem with the bluetooth and the wifi card itself.
  2. This is a common issue with people with Intel’s AX200 chips (Although it might be a correlation, not causation).
  3. Nothing online is helping. Usually it’ll just get rid of the error and stop at “[ OK ] Started Accounts Service.”
    I have been digging and trying different things to get it to work every now and then, but at this point, I’ve done enough searching that I’ll just wait for someone who can help me out because I have no idea what I’m doing. Going past 2 pages in any search browser shows absolutely nothing relevant and changing out different terms to get different results will just end up back to number 3 of what I said before. I was thinking of finding a way for it to output a log to see what went wrong but I’ve been pretty busy lately. If you find anything useful, let me know please and thank you.

The bluetooth issue is harmless. Bluetooth should still work. It’s not the reason why it stops booting.

But this on the other hand.

You could try and boot directly into text mode. No login manager. Disable whatever you are using. When logged in try starting x with startx.

1 Like

Sorry, how do I do that?

1 Like

I get this error after I did chroot, I don’t know why it’s happened and I never used bluetooth.

Try CTRL+ALT+F2 when it hangs or F3, F4, F5 then login when you get the prompt.

Then disable sddm, lightdm gdm whatever you are using with this command

sudo systemctl disable sddm.service or lightdm.service or gdm.service . I dont know wich you use.

Then reboot. You should get to a prompt with only text


Ok I found out that it was lightdm, but when I log in now, it flashes some lines of whatever it is and quickly disappears.

Edit: I worded that badly. When I log in now, it flashes some text and quickly disappears, bringing me back at the login screen. Logging into tty2 works fine, but for some reason it does like a login loop on me when I go back.

Good. Then maybe someone else can help you further if it’s not resolved completely because I need to go out for a while. Try installing sddm and enable it. Leave lightdm disabled. See if that works better.

I appreciate the help man

No problem :slight_smile: Did it solve your issue? If so mark it solved :+1:

DHDK it’s worked for me but after then as I installed gdm, I installed gdm with chroot because I was needed connect to network in order installed gdm. If you have question feel free.

1 Like

Unfortunately it didn’t work. It stopped at “[ OK ] Started Network Manager Script Dispatcher Service”. I eventually gave up and chose a different distro. Thanks for the help.