Bluetooth - Have a problem with Logitech MX Keyboard in KDE Plasma?

An observation / a fix I discovered with my Logitech MX Mini Bluetooth Keyboard in Enveavour KDE Plasma desktop.
The same probably applies to all Linux distributions.
I hope this info helps other users of Logitech MX keyboard (and mouse).

This solution is about using two or more kernels and Logitech MX bluetooth keyboard not working - in KDE Plasma.

I installed Enveavour OS with KDE Plasma desktop and with standard and Zen kernel.
I disabled Kdewallet - as I always have done as a first thing in KDE Plasma install - and activated bluetooth and connected MX Keyboard with no problems.
But when I rebooted and changed to Zen kernel I could not connect to MX keyboard anymore. The keyboard was available as a bluetooth device - but trying to connect resulted with an error.

I did not understand this at the beginning - suddenly bluetooth stopped working - only by changing the kernel - and I thought the fault was in bluetooth.

But I found the solution:
The same Logitech MX Fast Key (1,2,3) does not work in both of the kernels - but instead one has to use another (of the three available) to each kernel.

(Background about Logitech MX Keyboard: It has three specific “Fast Keys” 1 -2 - 3 to quickly change between three bluetooth devices - computers - mobile phones - tablets.)

However, if you use Kdewallet - which is enabled by default in Endeavour OS - this problem does not exist.

In my previous KDE Plasma installations I have always disabled KDE Wallet because it caused problems. But with this new bluetooth keyboard I decided to to use it (after discovering this behaviour of the keyboard - and only reluctantly).

So a user of Logitech MX keyboard has two options:

  1. to use KdeWallet
  2. or to use separate Fast Keys in every kernel

About KDE Wallet: If and when you use it - do not make the mistake of choosing the default GPG (GnuPG) encryption - the wallet does not support it ( ) - but instead choose the Blowfish encryption.

If you make the mistake of choosing the GPG encryption, WWW browsers like Brave and Firefox will use it - And every time you start your WWW browser - You will have to type the GPG password (since KDE Wallet does not understand it).
This behaviour of KDE Wallet to suggest GPG encryption at all - and by default!!! - is an old bug in KDE Plasma.