Bluetooth doesn't work after reboot

I followed the instructions to activate the Bluetooth (https://discovery.endeavouros.com/bluetooth/bluetooth/2021/03/) and it worked wonders, but after a reboot, doesn’t work anymore, instead KDE displays the bluetooth search tool on notifications, while bluedevil on sys settings don’t even recognize the bluetooth as active. I have an external bluetooth adapter, and already tried changing usb ports. im using kernel 5.15.27-1-lts. here’s my useful info:

Bluetooth section on inxi -Faz:

Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-1.3:4 chip-ID: 0a12:0001 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends

Print of the situation:


rfkill shows the service as unblocked.

I’m going to guess that you used systemctl start bluetooth to start the service once, but not systemctl enable bluetooth so it would start automatically each boot.

What’s the output of

systemctl status bluetooth

?

I did use sudo systemctl enable bluetooth, and here is the outputs of systemctl status bluetooth:

● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Sun 2022-03-13 18:46:17 -03; 16min ago
       Docs: man:bluetoothd(8)
   Main PID: 341 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 6970)
     Memory: 2.3M
        CPU: 33ms
     CGroup: /system.slice/bluetooth.service
             └─341 /usr/lib/bluetooth/bluetoothd

mar 13 18:46:17 borges-linux systemd[1]: Starting Bluetooth service...
mar 13 18:46:17 borges-linux bluetoothd[341]: Bluetooth daemon 5.63
mar 13 18:46:17 borges-linux systemd[1]: Started Bluetooth service.
mar 13 18:46:17 borges-linux bluetoothd[341]: Starting SDP server
mar 13 18:46:18 borges-linux bluetoothd[341]: Bluetooth management interface 1.21 initialized

Next question, did you just update your kernel but not reboot?

this is a fresh installation with the lts kernel provided by the installation process

EDIT: (hang on, i’m about to paru and reboot to see if anything changes)

What does this show?

bluetoothctl scan on

Try setting autoenable to true in /etc/bluetooth/main.conf

No default controller available

ok, i changed right now, rebooting again…

Edit: nothing changed

Do you have bluedevil installed.

Yes
image

Try

modprobe btusb

did it, shall i reboot ?

No i don’t think you need to. What does this show?

rfkill list 
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

It’s a bluetooth usb dongle?

lsusb

Yes it is

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 001 Device 003: ID 04f2:b351 Chicony Electronics Co., Ltd  HD Webcam
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Well it’s listed so it see it.

Bus 001 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

This is KDE. Did you turn on bluetooth in the bottom right corner hidden icons. Or under settings?

if i go to settings, the only option available is to click enable, and if i click, nothing happens.

if i go to the bluetooth hidden under notifications widget, it begins to scan devices, but none bluetooth device is listed