Bluetooth Broadcom BCM43142A0

Hi Rick, A personal thanks for all you do in the community. It seems you are answering and solve everything.

While replying the right panel said to reply I can reply with a message. Since I have no idea how to send messages when I went to my profile and tried to clieck the envelope icon (that’s greyed out), so I decided try this out.

But to the bluetooth. I did not understand what you meant by having to go through all the steps again. Do you mean I should follow the ?

I just don’t know enough about firmware and drivers. Would I be better off to remove everything and start over if you cab give me the steps.


PS: What are the steps, should I want to message someone again?

You click on your user icon top right corner and click on the envelope twice i think? Then you can send a pm or private message.

Edit: All of the information is on the wiki page. It has information and instructions and links to the arch wiki also.

It worked. Needs to be explained better, even on the Discourse help pages.
Thanks once again.

As far as i know the firmware file is proprietary and isn’t always included. Only on Windows. It is also my understanding bluez-utils is required? Other than that it’s a matter of having the right bluetooth packages installed and some already have those included like Gnome I think? Then you have to have the bluetooth service running. Then you try to connect and sometimes the GUI software works out of the box if everything is installed and running. Other times you need to use bluetoothctl and go through the process which sometimes requires removing everything and starting from scratch because it may pick up the wrong hardware id or something or pair with something else it finds.

Ok, I will uninstall everything and try that.

Broadcom sold the division. The new owners Lite-On changed the vendor code which stopped the driver.

status  from 2022-04-03 14-30-46

So why were we able to activate it on KDE, but not with Gnome?

I dug around and found this page. Can I get the Windows driver and convert it to hcd?

sudo systemctl enable --now bluetooth

You can install the firmware

yay -S --noconfirm bcm43142a0-firmware

[michael@eos-22 ~]$ yay -S --noconfirm bcm43142a0-firmware
:: Checking for conflicts…
:: Checking for inner conflicts…
→ Package conflicts found:
→ Installing bcm43142a0-firmware will remove: broadcom-bt-firmware-git (bcm43142a0-firmware)
→ package conflicts can not be resolved with noconfirm, aborting

You already have a git package installed. I don’t know if it’s the same. This installs this package so it may be the same thing. I don’t know what you issue is?

bcm43142a0-firmware 1201710-8 0.81 MiB

Edit @Stagger_Lee is probably correct. I don’t i use gnome. I use KDE btw! :wink:

Edit2: I only know it needs the firmware to work. I don’t know gnomes’ desktop.

As discussed in your last topic on this driver, I really don’t think there’s any problem with it.

You’ll want the AUR package broadcom-bt-firmware-git installed. That contains bcm43142a0-firmware.

You’ll probably want to have gnome-control-center installed. That should pull in both bluez and gnome-bluetooth as dependencies.

So, assuming you have those packages installed:

systemctl enable --now bluetooth

That doesn’t work?

1 Like

I don’t use GNOME either. Can’t stand it, to be frank. But the above steps worked in the OP’s last post on this topic.

I was going to say that! Ya I don’t understand what the OP is asking? It should work easily with the right packages installed. I just needs the firmware for the bluetooth to work as far as i know!

It works. I uninstalled and reinstalled those two and Gnome Control Center activated it. Thank you for your help, once again!

I am losing my mind :crazy_face: but I could not recall exactly which files worked. Now I have it.

If i was using Gnome I’d probably go off the deep end too! :rofl:

Maybe KDE is not ready for me yet :rofl:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.