Blender closes when any new Blender's window is closed

Hi.
I’m a new user of EndevourOS and Plasma, and I’m, loving them.
I don’t know if is this the right category for my topic (I have never used a forum before).
My issue is the next, from today when I close the “render result” window or the “preferences” window, or any new Blender’s window, it closes the whole program.

I’ve tried the other desktop environments, reboot, download other Blender versions, I’ve not made any changes in the system.

Could somebody help me please?
Thank you

1 Like

Carlos;
Welcome to the EndeavourOS forum, and thanks for giving EndeavourOS a try.
I hope you enjoy your time here.

I have never used Blender, but I am sure there are people here who can help.

Pudge

1 Like

Hi, @Pudge.
Thank you!
EndevourOS is aswesome!

1 Like

Which Blender Version, your last Blender update has this error?
Version before work?
Which Kernel?
GPU?
AMD/nvidia?

blender 2.82.a-3

Work fine for me.

All in all, we need more Details :wink:

3 Likes

When I wrote that, SGS is exactly the person I was thinking of. You are in good hands Carlos.

3 Likes

Thank you!
I’m using Blender 2.9 since the EndevourOS installation (last week). It didn’t happen before (from today is the problem).

  • GPU AMD Radeon HD 6750
  • Kernel 5.6.6-arch1-1
  • Plasma 5.18.4
  • KDE Frame 5.69.0
  • 64 bits
  • Processor 8x AMD FX 8120
  • RAM 15.6

It happens with 2.82 (official), 2.83 and 2.9 I’ve test them with factory settings. I know my GPU is in the limit, there are things that I can’t use or make, but it (close external window/close aplication) was never happened with EndevourOS or Ubuntu Studio (my last OS).

Thanks!!

Start Blender in the terminal/console and see what error message appears when it crashes.

Then it would be interesting to know what is in your update history when this error occurs.


pacman -Qi 'blender'
                                                                            ±[A3][master]
Name                     : blender
Version                  : 17:2.82.a-3
Beschreibung             : A fully integrated 3D graphics creation suite
Architektur              : x86_64
URL                      : http://www.blender.org
Lizenzen                 : GPL
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : libpng  libtiff  openexr  python  desktop-file-utils  python-requests  shared-mime-info  hicolor-icon-theme
                           xdg-utils  glew  openjpeg2  python-numpy  freetype2  openal  ffmpeg  fftw  boost-libs  opencollada  alembic
                           openimageio  libsndfile  jack  opencolorio  openshadinglanguage  openimagedenoise  jemalloc  libspnav  ptex
                           opensubdiv  openvdb  log4cplus  sdl2  embree
Optionale Abhängigkeiten : cuda: cycles renderer cuda support
Benötigt von             : Nichts
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 259,34 MiB
Packer                   : Sven-Hendrik Haase <svenstaro@gmail.com>
Erstellt am              : Fr 24 Apr 2020 14:06:14 CEST
Installiert am           : Fr 24 Apr 2020 17:21:24 CEST
Installationsgrund       : Ausdrücklich installiert
Installations-Skript     : Nein
Verifiziert durch        : Signatur

If it is the same on different DE (KDE, Xfce) it should be due to Blender.

Have you already downloaded the latest version directly from the homepage?
It is unpacked in a folder and has everything it needs.

Thank you.
How do I get the update history?
Yes all the downloads are from the Blender page, all the files are in the folder, as this was not happen before, I believe there is nothing missing, I have not changed anything in the system, the only difference are the many updates. Too I’ve downloaded it via Discovery

I can’t run it with pacman, but the terminal shows this crash file… blender.crash.txt

Blender 2.90 (sub 0), Commit date: 2020-04-23 21:08, Hash 826f6dd9ee20

Font List Refreshed # Info

backtrace

./blender(BLI_system_backtrace+0x1d) [0x698e65d]
./blender() [0xc1b70f]
/usr/lib/libc.so.6(+0x3bd70) [0x7fc2befcbd70]
/usr/lib/dri/r600_dri.so(+0x66fc4a) [0x7fc2a2287c4a]
/usr/lib/dri/r600_dri.so(+0x7a247b) [0x7fc2a23ba47b]
/usr/lib/dri/r600_dri.so(+0x7a24b2) [0x7fc2a23ba4b2]
/usr/lib/dri/r600_dri.so(+0x13572a) [0x7fc2a1d4d72a]
/usr/lib/dri/r600_dri.so(+0x137553) [0x7fc2a1d4f553]
/usr/lib/dri/r600_dri.so(+0x143156) [0x7fc2a1d5b156]
/usr/lib/dri/r600_dri.so(+0x140176) [0x7fc2a1d58176]
/usr/lib/dri/r600_dri.so(+0x131fcb) [0x7fc2a1d49fcb]
/usr/lib/dri/r600_dri.so(+0x370f7d) [0x7fc2a1f88f7d]
/usr/lib/dri/r600_dri.so(+0x371034) [0x7fc2a1f89034]
./blender(immEnd+0x2f9) [0x569afb9]
./blender(ED_region_do_draw+0xbaa) [0x122785a]
./blender(wm_draw_update+0x52d) [0xec979d]
./blender(WM_main+0x30) [0xec7740]
./blender(main+0x321) [0xb52331]
/usr/lib/libc.so.6(__libc_start_main+0xf3) [0x7fc2befb7023]
./blender() [0xc17f3c]

Here is the update history
https://pastebin.com/nwxEtBVp

I ran Manjaro on a virtual machine and there is no problem there. Maybe some of the updates didn’t work well for me in EndevourOS.

For example, you can install package pahis (PAckage HIStory) and use that.

3 Likes

Use service like pastebin.com if its to long :+1:

2 Likes

Thank you!

Thank you

I suspect a mesa drivers problem.

Try rolling back some of the packages that were updated from the last time Blender was working correctly and see if the problem is solved.

You can rollback packages by using the downgrade command (you might need to install downgrade first ( yay -S downgrade)

2 Likes

Thank you!
That’s the answer, it works perfectly!
Thank you @nate!
And thank you all who helped me!!!
I love this community!

2 Likes