Blank screen with lightdm

I installed EndeavourOS with the MATE desktop, choosing auto-login and encryption in the installer. Now when system boots I get a blank screen as soon as I see the messages about lightdm starting. Switching to other ttys doesn’t seem to work, so I have to power off.

If I disable the lightdm service with systemctl, linux boots normally in text mode, then I login and type “systemctl start lightdm” to start the dm manually and it works. But if I reenable the service and reboot, I get the blank screen again.

Any idea what could be the problem? This is an amd 4700u (vga 7) laptop so maybe its igpu is not well supported yet?

EDIT: I have also tried with the slim DM but I get the same result


It sounds strange: But do you have the possibility to connect another monitor for testing?
I had the same problem and it was on my monitor (Terra LCD). Different monitor, and everything worked…

This may or may not help, but you might want to try using the other Display Managers.

Note that the Welcome app has the Change Display Manager button (under the After Install tab), but you can change it manually as well.

1 Like

I’ve already tried with the slim display manager, but the problem remains.

However if I disable lightdm and start the lightdm service manually with systemctl, it starts and I can see the desktop. I also see an amdgpu error in dmesg: “failed to add display topology” but since the desktop works if started manually I don’t understand where the issue is.

EDIT: it seems other distros have similar problems with this laptop.

Would be great to explain the all start of your bug in spite to open threads everywhere maybe it would help us more in giving us the information we need !

I opened 2 threads because they were 2 different problems: first the partitioning in the installer, which I marked as solved, and now the display manager, which prevents me from using the desktop. If you feel 2 threads are too much for this forum feel free to delete them.

It’s not the way of EndeavourOS to delete threads but if you want us to help you correctly, give us the information and feedback from our help, it will work better…

I think you misunderstood @FLVAL, don’t forget that this forum is used by an international community who don’t have English as their first language. Sometimes things can get lost in translation.

What FLVAL meant is that in this particular thread your hardware specs weren’t shown, which is much easier for the community to help you further. It is in no way be meant as an imposition from our side, not everybody reads every thread, most users will open a thread if they think they can offer help on the matter and if your first thread isn’t in their level of help they wont open and read it.

That’s all… :wink:

Have you looked at dmesg? Maybe you can check & post. It may require to boot with a kernel parameter possibly?

I have the same APU and had the same problem (not an amdgpu issue, probably a bug in lightdm?)

Fix is simple: install sddm and enable it, then remove lightdm. You can reenable auto-login by following the instructions here:

Is this on Mate also?

Edit: I don’t get that problem on Mate with my RX590 with lightdm.

@FredBezies linked this to me earlier today:

There are a few sections there might be useful, e.g. “LightDM does not appear or monitor only displays TTY output” and “Long pause before LightDM shows up when home is encrypted”

1 Like

@FredBezies is the Mate man for sure.

1 Like

I was… I migrated to Gnome six weeks ago.

Oh gno!

(I think I’m pretty much MATE for life… I try GNOME occasionally but I just can’t get on with it)

1 Like

I did the same three weeks ago. Added dash to panel and arc menu and haven’t looked back since. :grinning:

1 Like

This is a surprise. I thought you were Mate for life?

I thought too. But Mate is too slow to move now and some things are not implemented for years like using gnomeweather instead of libmateweather for example.


Why would you need weather in a DE - when cross-DE solutions (read conky-driven) solutions exist and are totally configurable?

No - that’s not my personal hobby-horse… it’s just a pony… :grin:

1 Like

That’s why I went with MATE: slow pace = stability :slight_smile: As a GNOME devotee, I spent way too much time reporting bugs and fixing inconsistencies after updates, not to mention those javascript bindings (memory leaks and so on…)