Blank Screen With Cursor After Update

Hello there :slight_smile:

So yesterday I ran yay to update my system while I was gaming and everything was fine until I finished my session and clicked shut down just to be greeted with a blank screen and the system not shutting down. When I restarted my system, a blank screen appears after systemd with the cursor which I can move. I can access the terminal with my keyboard shortcut but I wasn’t sure what to do from there. After researching online the usual suspects were as always NVIDIA drivers, so I decided to try and downgrade them from pacman’s cache using chroot from a live usb.

The version I updated to is 550.54.14-4 and I tried to downgrade it to 545.29.06-4, however when I use
pacman -U with nvidia-utils I get this output:

loading packages…
warning: downgrading package nvidia-utils (550.54.14-4 => 545.29.06-4)
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (545.29.06-4) breaks dependency ‘nvidia-utils=550.54.14’ required by lib32-nvidia-utils
:: installing nvidia-utils (545.29.06-4) breaks dependency ‘nvidia-utils=550.54.14’ required by nvidia-dkms

When I try to downgrade lib32-nvidia-utils and nvidia-dkms (yes I know I shouldn’t have it unless I’m using multiple kernels I just learned that today not sure why I had it in the first place) I get these outputs:

dkms:
loading packages…
warning: downgrading package nvidia-dkms (550.54.14-4 => 545.29.06-4)
resolving dependencies…
warning: cannot resolve “nvidia-utils=545.29.06”, a dependency of “nvidia-dkms”
:: The following package cannot be upgraded due to unresolvable dependencies:
nvidia-dkms

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency ‘nvidia-utils=545.29.06’ required by nvidia-dkms

lib:
loading packages…
warning: downgrading package lib32-nvidia-utils (550.54.14-1 => 545.29.06-1)
resolving dependencies…
warning: cannot resolve “nvidia-utils=545.29.06”, a dependency of “lib32-nvidia-utils”
:: The following package cannot be upgraded due to unresolvable dependencies:
lib32-nvidia-utils

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency ‘nvidia-utils=545.29.06’ required by lib32-nvidia-utils

If I click yes it says there’s nothing to do

My kernel is up to date and I use KDE. My GPU is a 1660ti. Obviously now I realise the importance of having backups and now I’m stuck. I’m not sure if the problem is with the drivers in the first place but I cannot confirm that without downgrading them.

When I ran inxi -Fxxc0z | eos-sendlog to share the output here I got this:
Authorization required, but no authorization protocol specified

Any help would be appreciated :slight_smile:

downgrade nvidia-dkms nvidia-utils nvidia-settings lib32-nvidia-utils

Then select the version you want.

I get the same outputs

Maybe you can try downgrading all the packages
3.2 How to restore all packages to a specific date

Tried it now and I get this:

:: installing expat (2.6.0-1) breaks dependency ‘expat=2.6.1’ required by lib32-expat
:: installing libelf (0.190-2) breaks dependency ‘libelf=0.191’ required by lib32-libelf
:: installing libffi (3.4.5-1) breaks dependency ‘libffi=3.4.6’ required by lib32-libffi
:: installing nvidia-utils (545.29.06-4) breaks dependency ‘nvidia-utils=550.54.14’ required by lib32-nvidia-utils
:: installing libblockdev (3.0.4-2) breaks dependency ‘libblockdev=3.1.0’ required by libblockdev-crypto
:: installing libblockdev (3.0.4-2) breaks dependency ‘libbd_utils.so=3-64’ required by libblockdev-crypto
:: installing libblockdev (3.0.4-2) breaks dependency ‘libblockdev=3.1.0’ required by libblockdev-fs
:: installing libblockdev (3.0.4-2) breaks dependency ‘libbd_utils.so=3-64’ required by libblockdev-fs
:: installing libblockdev (3.0.4-2) breaks dependency ‘libblockdev=3.1.0’ required by libblockdev-loop
:: installing libblockdev (3.0.4-2) breaks dependency ‘libbd_utils.so=3-64’ required by libblockdev-loop
:: installing libblockdev (3.0.4-2) breaks dependency ‘libblockdev=3.1.0’ required by libblockdev-mdraid
:: installing libblockdev (3.0.4-2) breaks dependency ‘libbd_utils.so=3-64’ required by libblockdev-mdraid
:: installing libblockdev (3.0.4-2) breaks dependency ‘libblockdev=3.1.0’ required by libblockdev-nvme
:: installing libblockdev (3.0.4-2) breaks dependency ‘libbd_utils.so=3-64’ required by libblockdev-nvme
:: installing libblockdev (3.0.4-2) breaks dependency ‘libblockdev=3.1.0’ required by libblockdev-part
:: installing libblockdev (3.0.4-2) breaks dependency ‘libbd_utils.so=3-64’ required by libblockdev-part
:: installing libblockdev (3.0.4-2) breaks dependency ‘libblockdev=3.1.0’ required by libblockdev-swap
:: installing libblockdev (3.0.4-2) breaks dependency ‘libbd_utils.so=3-64’ required by libblockdev-swap

Essentially the same problem. With nvidia-utils amoung the packages that can’t be downgraded. Guess I can’t do any downgrading without solving this dependancy thing which I don’t know how to do.

StressedKen calm down and everything will be okay.

Do you know if you’re using X11 or wayland as your desktop session?

You can try using nomodeset from the kernel command line to get into your desktop, and fix the issue from there. And the first thing you want to do is make sure you’re using X11, because nvidia drivers and wayland tend to produce the errors youre describing.

I use X11
Not familiar with nomodeset tho

You could always try reverting to nouveau.

nvidia-inst -n

Typed the command and the terminal told me to run:
yay -Syu xf86-video-nouveau

So I do that and it installs successfully but when I restart it’s the same blank screen
Not sure if it actually switched drivers tho
Also when I ran that command it asks me whether to Replace kcolorpicker with extra/kcolorpicker-qt5 and Replace kcolorpicker with extra/kcolorpicker-qt5 and I say no because if I say yes it hits me with the “breaks ascendancy” error I keep getting when I try to literally do anything.
Not sure if that’s relevant so thought I should mention it.
Another thing I should mention is that throughout this whole thing the resolution became very wide. The terminal window is very wide and when I manage to open my web browser from it the bookmarks tab is also very wide. Maybe if there’s a way to change the resolution from the terminal something would change ?

Yeah I give up. I’ll copy my important files from the live usb and reset the system I guess. I was hoping I’d learn something new but at this point it seems there’s nothing I can do. I’m not sure how I can prevent this from happening in the future (aside from backing up the system ofc) when a simple yay command can break everything. Any advice regarding that or system backup would be appreciated. Thanks everyone for the help.

So turns out the problem was probably caused by kde updating to kda 6
Since I use auto login, it probably logs in using Wayland instead of X11 which causes the issues
Kde with X11 works just fine

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.