Blank screen after idle time

Over the last few days, I’ve started experiencing a strange issue where I can’t get back into my windows manager (LXQt) after the computer stood idle for some time (+/- 20 minutes). I can drop into a virtual terminal (CTRL+ALT+F3) and start SSDM, though it’s a little buggy (lots of panels/windows fail to load).

Anyone else experiencing this type of problem?

Additional Information
After a system upgrade that might have updated the Nvidia proprietary drivers, my system complained that it was unable to run xscreensaver. I, therefore, disabled the screen saver and all power saving options. This includes the option to lock the screen when idle.

Also, there’s nothing in the .xsession-errors log.

Hardware Info

Things I’ve tried to resolve the issue…

  • Disabled the screensaver (screensaver).
  • Disabled all power saving options.
  • Disabled “lock screen” after idle time.

Things that I’m considering doing…

  • Switch to nouveau drivers.
  • Switch to LTS kernel.

Can anyone recommend any other possible solutions to consider.

i dont kknow , but you might downgrade nvidia version before current.

with downgrade (nvidia-driver) or look in /var/cache/pacman/pkg/

to look for older nvidia package and pacman -U (that file)

if that worked then can you confirm it is the nvidia driver…
lts kernel you can always add !

dont forget to mkinitcpio -P after downgrade, to be certain…

then you can always try nouveau, try to downgrade the nvidia driver…

i would first check if updating system, reinstall nvidia driver and rebuilding kernel-images do the trick.
It happens on archbased that kernel and nvidia is not updating on exactly the same time what cause issues like you have.
the new hook for rebuild images on nvidia update can prevent from that: endeavouros/nvidia-hook
sudo pacman -S nvidia-hook

Thank you @joekamprad and @ringo for your suggestions. Also, apologies for not responding earlier… been swamped with work.

The problem has largely resolved itself after I did some updates, but I’m definitely going to try @joekamprad’s suggestion. I will mark it as the solution once I find an opportunity to try it.