Blackscreen after booting a Live USB

The system boots okay but the thing is it will simply go into blackscreen. When I press ctrl+alt+f2 I am able to see the command prompt BUT it asks for the EndeavourOS login and password and this is where I am getting stuck. Any ideas? The card is “blacklisted” when booting - using an older nvidia dedicated GPU in an old desktop my friend gave me. The PC is like 15 years old. I just need to start the Live USB and proceed with the installation but so far I am stuck at the command prompt and I am clueless about what to do.

I have tried to do some troubleshooting and I have found this but no luck since I am stuck at the login / password. Any ideas on how to proceed? Thank you very much

What is the card exactly?

Nvidia GeForce 8600 GT

Have you tried booting with nomodeset?

yes sir I did

I have tried to install Arch to this PC - turns out the problems are with the legacy nvidia drivers

when I am using nouveau drivers and remove those nvidia ones - the system works just fine but when I use the nvidia-340xx-dkms or anything else the system goes bananas and all I can do is using command prompt

however when I am trying to try this with the EndeavourOS I cannot log in to the system since it asks me for login / password and I am pretty lost at that point

Arer you booting on the default grub entry? Not the nvidia. This will install with nouveau open source drivers. Did you try that?

Yes please. Actually I have tried all the boot options - it is either blackscreen or xorg giving me an error that there are no screens.

I didn’t understand this part? If you can’t install how are you doing this?

Are you saying here you have it installed and it’s a black screen? I’m just not following you.

Edit: If you have installed it and it boots to a black screen you can switch to a tty and try to install the 340.xx version drivers from the AUR

Use root and your password

yay -S nvidia-340xx

1 Like

Sorry, I’ve just forgot to mention I’ve tried to install Arch on the same pc and I had the same problem but I’ve managed to solve it. I’ve just removed all the nvidia drivers once the arch is was already installed on my computer and then I’ve installed the nouveau drivers only instead. I have also installed sddm and KDE Plasma and after some tinkering with those drivers I have managed to make it work. So because I have been able to install Arch and tinker with the OS a bit I know that the problem is with the drivers for the legacy nvidia gfx (geforce 8200).

As for the LiveUSB with EndeavourOS I was not able to copy the process because I am only able to boot from the USB into the command prompt (trough ctrl+alt+F2) but the GUI wont start. I was trying to do the same via command prompt but the system is asking me for the login / password so I cannot fully access the command prompt to do the necessary operations in order to run the OS from the USB device but with the GUI running. Hence I am kind of stuck at the login / password screen after booting the EndeavourOS Live USB. So my problem here is that I cannot access the command prompt fully. Hope I have made it at least a bit more clear - sorry again for the chaos in my posts and thanks for your help!

user = liveuser or if that dont work put in live-user pass leave blank

also unclear what boot option is used on try to boot EndeavourOS ISO from USB.
If you try to use Nvidia boot option on a legacy GPU system it will never be able to boot up the GUI session.
And you can not install EndeavourOS from cli… so login to a TTY will not help you …
ISO should boot directly into the Desktop without the need to enter any username or password.

And to boot ISO on a legacy GPU system you must use default boot option and never the nvidia boot option.

This is what I mentioned earlier if the OP tried booting on the default grub entry so it would be using nouveau. My understanding is that it still booted to a black screen.

NV84 (G84) NV50 family (Tesla) should work fine on nouveau… but could be also something else causing issues on a system with such old hardware in use…

ISO has no grub…

Okay…i mean the default entry in the menu. :wink: