Black screen with Steam, fix included

I just found that when I loaded steam I was met with a black screen.

I did some searching and found this link:

This lead me to downgrade freetype2 from the arch archive using the following command:

sudo pacman -U https://archive.archlinux.org/packages/f/freetype2/freetype2-2.10.4-1-x86_64.pkg.tar.zst

I’ve now added freetype2 to my ignored packages in pacman.conf until I read about a fix.

6 Likes

Thank you very much for sharing that!

I had this problem too.

In the reddit sub you have linked it is described for a solution to enlist into the steam-beta after downgrading the package. Then you have to wait until the steam-patch is done and upgrade the freetype2-package back again afterwards.

I have tried it this way and steam-runtime (beta) works normally for now. I will try to retreat from beta again as soon as valve update the steam-client next time. Maybe then the beta-version won’t be necessary anymore.

1 Like

Just switching to beta under menu: steam/settings worked for me.

2 Likes

It is also mentioned here with fix…

Steam not working right on Arch Linux? It’s an issue with FreeType and there’s a fix

1 Like