Black screen with linux-zen and linux-tkg-pds on boot with AMD 5700 XT

So, this is weird.

I used linux-tkg-pds without problems on manjaro, but somehow on EOS/Arch I have a hard time booting it. It did work but it is always a bit of a hit and miss and sometimes I can boot and sometimes I keep getting a black screen and hear my videocard fans blasting.

Then I tried linux-zen and I have the same issue there.

Then I went to the normal default kernel and no problems.

It might be that the latest version of the linux-tkg-pds has this problem and the next release might fix it, but I don’t know where to find a boot log of sorts that tells me where the boot is hanging on that is causing it to stall.

I will give the linux-tkg-pds another go when it releases with the 5.8 kernel, but thought might as well make a topic, maybe someone else have had the same experience.

I had the same issue on the linux-zen, sometimes it would load to a black screen with the mouse. If i waited eventually it would load or i could ctrl+alt+f2 then switch back with ctrl+alt+f1 and it would load.

I also had random system reboots on 5.7 with ryzen 5 and 5700xt which seems to have been fixed with 5.8 rc7

Tried the newest 5.8 linux-tkg-pds but still the same issue. So weird.