Black Screen with Docking Station

I use a Lenovo IdeaPad 5 14are05 with a ThinkPad Universal USB-C Dock.
My setup uses an encrypted EOS installation with systemd-boot and dracut.

If I reboot the machine with connected dock all displays stay black.
So my current workaround is disconnecting the dock before rebooting.

Now i wonder where the cause of the problem is.
Is there a dracut module missing? Or is systemd-boot incompatible with encryption?
Or does my hardware sucks?

Has someone a similar setup with or without this problem?

Have you tried flipping the usb-c cable. Although it sounds dumb sometimes these things are that simple. It has worked for some users. Other then that is there a firmware update for the dock?

Edit: It also wouldn’t hurt to post the hardware. Post the url

inxi -Faz | eos-sendlog

Edit2: Is this the Thunderbolt 4 dock?

I wouldn’t express it that way. It seems an opinionated feature of many Laptop vendors, including Lenovo, to use an external display for boot, when one is present (while blanking the laptop display).
That’s what my similar Lenovo does.

IMHO, encryption is probably not the problem, rather USB-C (dock) drivers. :person_shrugging:

The odd thing is, if i connect the dock after the boot process, it just works.
You can see in the inxi, there are two DP connected.
So the cable is okay and the dock worked fine in other DE-installations in the past.

My real problem is, i did a firmware update for the laptop before the eos installation and
after that a firmware update for the dock (with fwupdmgr). So right now i don’t know, where to begin debugging first :laughing:

My gut says it’s systemd-boot because my other installations were grub an they worked.
So maybe i will try switching this and see if this solves the problem. I was just curious if there is a known problem with dock setup and systemd-boot/dracut.

1 Like

Did you try this with the dock? Have you tried flipping the usb-c cable?

Hi CC,

So I am running a Thinkpad T450 and T470s in the Lenovo Ultra dock with 2 monitors.

So I agree with the others, before you do anything install:

  1. Sign into Windows, Install the Lenovo App, and upgrade the firmware on the Dock and Laptop.

If the cable is working after it boots in … then usually it is not a bad cable. Bad cables or low voltage usually means we will see intermintent disconnects to the hardware. Or when we change display settings like monitor orientation it could re-initialize.

So is this setup a KDE Desktop?

I’m not saying it’s a bad cable. Sometimes just flipping it over for what ever reason has worked reported by some. Have no idea why but for some it worked others it did not. :man_shrugging:


Oh its a magic trick (lol)? I was looking at CC past posts and it looks like he is using Gnome.

I’m still on vacation and will do some more testing afterwards.