Black screen with Cinnamon on a Lenovo Thinkpad T440 laptop

Hello friends from all over the world :grinning:
I am having a strange boot problem with Cinnamon on a Lenovo Thinkpad T440 laptop. Indeed, after the grub screen I have a black screen! By adding the option nomodeset in the edit mode of the grub at startup, I can start and I have the login screen!
Strangely, I installed the DE Gnome and the boot is done without problem!
If you have an idea? A problem with Cinnamon?
I am posting the result of the inxi -Fxxxz command, the integrated graphics chipset is Intel Haswell-ULT.

[jeffou@Thinkpad-T440 ~]$ inxi -Fxxxz
System:
  Kernel: 5.12.1-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: Cinnamon 4.8.6 tk: GTK 3.24.29 vt: 7 dm: LightDM 1.30.0 
  Distro: EndeavourOS base: Arch Linux 
Machine:
  Type: Laptop System: LENOVO product: 20B7S2C900 v: ThinkPad T440 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20B7S2C900 serial: <filter> UEFI-[Legacy]: LENOVO 
  v: GJETA4WW (2.54 ) date: 03/27/2020 
Battery:
  ID-1: BAT1 charge: 32.3 Wh (75.8%) condition: 42.6/47.5 Wh (89.6%) 
  volts: 11.5 min: 10.8 model: SANYO 45N1767 type: Li-ion serial: <filter> 
  status: Discharging 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse B330/M330/M331 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
CPU:
  Info: Dual Core model: Intel Core i3-4030U bits: 64 type: MT MCP 
  arch: Haswell rev: 1 cache: L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 15173 
  Speed: 798 MHz min/max: 800/1900 MHz Core speeds (MHz): 1: 798 2: 1896 
  3: 1896 4: 1898 
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo driver: N/A 
  bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300 
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo 
  bus-ID: 2-8:5 chip-ID: 04f2:b39a class-ID: 0e02 
  Display: x11 server: X.org 1.20.11 driver: loaded: intel,vesa 
  unloaded: fbdev,modesetting resolution: <missing: xdpyinfo> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403 
  Device-2: Intel 8 Series HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.1-arch1-1 running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.27 running: no 
Network:
  Device-1: Intel Ethernet I218-V vendor: Lenovo driver: e1000e v: kernel 
  port: 4080 bus-ID: 00:19.0 chip-ID: 8086:1559 class-ID: 0200 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Realtek RTL8192EE PCIe Wireless Network Adapter 
  driver: rtl8192ee v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:818b 
  class-ID: 0280 
  IF: wlan0 state: down mac: <filter> 
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus-ID: 2-7:4 chip-ID: 0bda:8761 class-ID: e001 serial: <filter> 
  Report: bt-service: disabled note: bt-adapter can't run. 
Drives:
  Local Storage: total: 585.01 GiB used: 70.76 GiB (12.1%) 
  ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
  speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 032 scheme: MBR 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Extreme Pro 
  size: 119.25 GiB serial: <filter> scheme: MBR 
Partition:
  ID-1: / size: 226.75 GiB used: 6.13 GiB (2.7%) fs: ext4 dev: /dev/sda1 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 49.0 C mobo: 0.0 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 197 Uptime: 1m wakeups: 3 Memory: 7.48 GiB 
  used: 957.8 MiB (12.5%) Init: systemd v: 248 Compilers: gcc: 10.2.0 
  Packages: pacman: 783 Shell: Bash v: 5.1.4 running-in: gnome-terminal 
  inxi: 3.3.03 

I wonder if its a problem with lightdm loading before the module is loaded? Look at troubleshooting section.

Thanks a lot for your answer, i’m newbie with EndeavorOS, i will read the troubleshooting. :ok_hand:

Not sure it will help but can’t hurt to try.

This is probably it. I’ve heard A LOT of people having similar issue with the 5.12 kernel.

Also, with an older Thinkpad like that, you may want to just run with the lts kernel (I do). You can download it with akm if you can login or at the login screen drop to TTY (I believe cinnamon is Ctrl+alt+f3, and then Ctrl+alt+f7 to return), and run this:

pacman -Syu linux-lts linux-lts-headers

And then update grub as well.

grub-mkconfig -o /boot/grub/grub.cfg

Reboot and choose lts in grub and hopefully you’ll be all set.

1 Like

@Jambalak

Also I looked at your hardware output and it doesn’t look like it loaded the module for the graphics. So you may also need to add MODULES= i915 to mkinitcpio.conf

sudo nano /etc/mkinitcpio.conf

add

MODULES= i915

Save the file and then run

sudo mkinitcpio -P

reboot

Thank you all, i see that tomorrow and i will get back to you.

It is resolved!
The idea of modifying the /etc/mkinitcpio.conf file and the kernel did not work.
The solution:
Connect in chroot (I use the live iso Sparkylinux Rescue to do that: https://sourceforge.net/projects/sparkylinux/files/rescue/sparkylinux-2021.03-i686-rescue.iso/download)
We have to set logind-check-graphical=true inside lightdm.conf under /etc/lightdm/
Uncomment the line #set logind-check-graphical=false and change from false to true
We turn off the pc and normally we finally have the lightdm connection window!
For information, I tested an installation with XFCE, we have the same problem because it uses Lightdm!
Thanks again for your ideas. :grinning:

1 Like

Thanks for the reply. I just gave you a couple of ideas as it seems a lot of people are having the same issue. I would like to confirm that this was on the 5.12.1 kernel? Have you updated to the 5.12.2 kernel now and it’s okay?

Interesting choice to chroot. What made you choose sparky Linux to do this? I thought that was Debian based?

i updated with a LTS kernel, but it’s the same pb if i comment the line logind-check-graphical in /etc/lightdm/lightdm.conf!
A vidéo to see the problem:
https://www.dropbox.com/s/5nsoy19ry8cq3jy/20210511_154832.mp4?dl=0
Strangely after a very long period, we still arrive on the Lightdm login screen!

Because there are a lot of tools for the maintenance of a PC and I’m more comfortable with Debian. :grin:
Sparky Linux rescue is a Debian testing.

I guess I’m more surprised it worked than anything. I’ve never tried to fix something Arch based with a Debian distro. It never even dawned on me to do so.

And what “tools” do you need? Basically all you should need is a terminal?

The tool is chroot. Because it’s easy and efficient, you do it in 3 clicks, chroot is not a process that we do often!


2 Likes

There’s no wrong way to Linux I suppose. I’m really glad it all worked out.

My suggestion for 99% of people - use the lts kernel unless you have some reason not to. If you don’t know why to use a specific different kernel, lts is the answer.

I didn’t choose anything, because i’am a newbie with arch. I took the default kernel when installing EndeavorOS. Moreover, we do not have the choice of the kernel during the installation, it seems to me. Anyway, it works for me, thank you for the help provided.

You can add packages in during the installation. Or you can install with akm or a tty and terminal upon first boot. The latest kernel must be used for installation in case someone does in fact need it. You do need to know you want the lts kernel and how to get it though. We are admittedly not geared towards newbies and first time users.

Welcome to the fun! Glad to have helped get things working again for you.

1 Like

Did this acutally solve it, or was it changing the kernel? I just want to make sure this is marked solved appropriately, especially since there’s a boat load of folks showing up with major problems due to updating the 5.12 kernel.

Yes, I confirm, this is the solution that solves my black screen problem at boot.
Go to the section troubleshooting
Changing the kernel did not solve the problem on my Lenovo Thinkpad T440 laptop.
The craziest thing is that I did not have this problem on another Dell E5520 laptop!
Sure, it’s a GPU issue.

Why? They aren’t identical computers. Now that would be wild if they didn’t have the same problem.