Black Screen on one monitor after Nvidia 555 stable update

I just updated my Nvidia 15050ti drivers from 550 to 555 and was exited because of fixes and all. My 550 was working fine from out of the box installed by nvidia-inst. Now after updating to Nvidia 555 with the same command, and then restating, my one monitor not working and showing black screen. SO I messed with many many commands and combinations to make it work. But failed to do so. So I decided to reinstall the OS and did it. But after updating system and installing nvidia 555, my one monitor not working. Only one monitor working out of two. I have dual monitor setup.

I think there is problem with Nvidia 555 stable on wayland.

I am running latest and updated KDE on Wayland
I have Nvidia 1050Ti GPU
I reinstalled EOS to fresh one
I am on Systemd
nvidia-dkms is also there


If there is no solution to this then please tell me how to downgrade to 550 ?

You can use the downgrade command to downgrade the nvidia related packages. I’m not sure if your issue can be fixed, but I do know that support for anything below the 2000 does not seem to be a priority for Nvidia.

1 Like

I don’t have multiple monitors but nvidia 555 drivers are working fine on Wayland with GTX 1060 gpu.

1 Like

i can confirm also zero issues with the Nvidia update running on a 3060 using nvidia-dkms Plasma on Wayland:

1 Like

The problem is with my dual monitor. One is working and another is not. Working fine with x11. But when I login with Wayland, its only one monitor.
Tried every possible method. I have had this probem on manjaro and ESO also but after following the archwiki instructions, the problem solved. But after this 555 update, it come back.

this is reported all over the place seems it does mixup with the display ID names.
Nvidia does this and in addition wayland and X11 too.
But i do not have issues at all this is also a dual display setup.
Possible it is partly caused by sddm you can apply the same settings as for the Desktop, and also possible that SDDM is still not running on wayland what causes issue on switching

1 Like

Yes, forgot to tell you that after giving up, I tried on cinnamon EOS too and x11 got same issue :smiling_face_with_tear:
SDDM is sometimes (one of my fresh installs, as I tried to install 3-4 times yesterday) shows cursor only on both the displays on Wayland.
What is the solution ?

This 2 things could be a workaround too:

1 Like

I found solution on Manjaro forum and if someone is facing similar issue then try this :smiling_face_with_tear:

The is problem is with the Kernel 6.9. Wayland KDE works fine on 6.6 LTS. So use 6.6 LTS kernel and add nvidia_drm.fbdev=1 on GRUB_CMDLINE_LINUX_DEFAULT or in cmdline file if you are using systemd.
Make sure nvidia_drm.modeset=1 also added there.
Also, verify that you have nvidia_drm in /etc/mkinitcpio.conf in the MODULES= or HOOKS= line.
Example :

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

If it was not present, then run sudo mkinitcpio -P after adding it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.