Black screen on my LAPTOP monitor screen but not on my EXTERNAL screen after NVIDIA driver install

Hello, I installed the NVIDIA driver, like it was on the Endeavour OS guide, and rebooted my PC. When I rebooted, only my external monitor shows me stuff, my laptop’s monitor is black. I tried unplugging my main monitor, or change something in the settings, but the monitor is not in the KDE display settings nor the NVIDIA settings. Can anyone help me?

GPU: NVIDIA GeForce RTX 3060 Mobile / Max-Q
GPU: Intel CometLake-H GT2 [UHD Graphics]

I came from Manjaro, everything worked there for a while, but now every update breaks there. If there is information that I can provide to this issue, I would happily provide it, if it means fixing my laptop.

I think you want to look at this page in the Arch wiki.

Probably configuring using xrandr or xorg config. It’s a place to start reading a bit. I have to go out for sometime right now. Hope this helps.

It’s also possible this is due to the internal wiring (i.e. the internal panel is wired to the iGPU).

You might need to configure Reverse PRIME though I’m surprised it would be necessary with your RTX3060 which should have proper render offload support… :thinking:

Did you configure the NVIDIA dGPU as your primary (e.g. via xorg.conf), or leave the iGPU as the primary to use the dGPU via render offloading with e.g. prime-run?

Did you check your UEFI Bios settings to see if there is a setting that automatically goes to discrete graphics card?

I don’t have a setting for that on this BIOS

I haven’t configure anything in my xorg.conf

Tried prime, but to no avail