Black screen on lock

I’ve gone through the screensaver settings and the power management settings. Screen saver is completely disabled and power management settings are set to not turn off my display after I lock the computer yet for some reason every time I lock it my screen it goes completely black. This does not happen in gnome, kde, lxqt or i3wm it is just xfce. How do I fix this so my screen stays on?



Screenshot_2021-10-06_20-25-18

Enable screensaver and turn on lock screen with screen saver. That’s what i did on mine otherwise it does go black until you click the mouse and then the login screen comes on.

One of the first things I did after the initial install was to get rid of the screensaver and install light-locker. Haven’t had any issues like yours since.

For me it’s not an issue. I don’t care if it goes black as long as it works when i want to log in which it does. But i changed it to give me screen saver on lock so that takes care of it anyway for me.

Ok, I’ve now tried installing light-locker, removing xfce4-screensaver, disabling xfce4-powermanager and using xset s off as well as xset s off -dpms. Yet every single time I lock my screen my monitor goes blank and says “no signal”. If I move my mouse it comes back on then after about 1 minute of inactivity goes blank and says “no signal” again.

this will get overwritten by xfce4 powermanager settings

Well, it’s not a perfect solution but I installed xscreensaver and in using that my screen no longer goes blank or says “no signal”. It will work for now. Not sure why other methods don’t work though.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.