Black screen after wake up from suspend


  • After waking up PC from suspension, the screen goes black.
  • I can hear sounds, like, music is playing, notifications arrives.
  • System does not respond to input and PC power button.

I’m not sure when this started to happen, maybe after a major update. I searched forums, can’t seem to find an answer. Enabling Nvidia services doesn’t help, moreover I disabled those specifically, because earlier I was dealing with graphical artefacts. Doing so helped get rid of glitches and system did suspension very well all this time until now. Feels like OS fails to load up something.

I’m not sure what logs to gather, but here are some:

inxi -Fxxc0z --no-host
  Kernel: 5.15.10-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
    Desktop: GNOME 41.2 tk: GTK 3.24.30 wm: gnome-shell dm: GDM
    Distro: EndeavourOS base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME B250M-A v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 0809
    date: 07/10/2017
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard
    serial: <filter> charge: 55% (should be ignored) status: Discharging
  Info: quad core model: Intel Core i5-7400 bits: 64 type: MCP
    arch: Kaby Lake rev: 9 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 3286 high: 3300 min/max: 800/3500 cores: 1: 3296
    2: 3291 3: 3300 4: 3259 bogomips: 24008
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Micro-Star MSI
    driver: nvidia v: 495.46 bus-ID: 01:00.0 chip-ID: 10de:1c02
  Display: x11 server: X.Org compositor: gnome-shell driver:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    resolution: 1360x768~60Hz s-dpi: 96
  OpenGL: renderer: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2
    v: 4.6.0 NVIDIA 495.46 direct render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
  Device-2: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f1
  Sound Server-1: ALSA v: k5.15.10-arch1-1 running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: d000
    bus-ID: 03:00.0 chip-ID: 10ec:8168
  IF: enp3s0 state: down mac: <filter>
  Device-2: Realtek RTL8192CU 802.11n WLAN Adapter type: USB
    driver: rtl8192cu bus-ID: 1-6:3 chip-ID: 0bda:8178
  IF: wlan0 state: up mac: <filter>
  Local Storage: total: 1.02 TiB used: 116.16 GiB (11.1%)
  ID-1: /dev/sda vendor: A-Data model: SU650 size: 111.79 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: Toshiba model: DT01ACA100 size: 931.51 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-1: / size: 111.49 GiB used: 26.78 GiB (24.0%) fs: btrfs dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 576 KiB (0.2%) fs: vfat
    dev: /dev/sda1
  ID-3: /home size: 111.49 GiB used: 26.78 GiB (24.0%) fs: btrfs
    dev: /dev/sda2
  ID-4: /var/log size: 111.49 GiB used: 26.78 GiB (24.0%) fs: btrfs
    dev: /dev/sda2
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swap/swapfile
  System Temperatures: cpu: 29.8 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
  Processes: 272 Uptime: 45m Memory: 15.57 GiB used: 2.86 GiB (18.4%)
  Init: systemd v: 249 Compilers: gcc: 11.1.0 Packages: 1261 pacman: 1250
  snap: 11 Shell: Bash v: 5.1.12 running-in: guake inxi: 3.3.11
journalctl -b -0 | eos-sendlog

“The elders scrolls”


Thought I read somewhere that this was a mainline kernel related bug.
Try running the LTS kernel, and see how that goes.
PS: use the pre-installed application “akm”.

1 Like

Ok, I installed LTS kernel using “akm”. Did suspend manually. Unfortunately, the issue still persists. Nothing changed, except grub is loading longer than usual now, before showing boot options, but that’s unrelated.

CPU: quad core Intel Core i5-7400 (-MCP-) speed/min/max: 3069/800/3500 MHz
Kernel: 5.10.87-1-lts x86_64 Up: 1m Mem: 2074.1/15947.0 MiB (13.0%)
Storage: 1.02 TiB (11.2% used) Procs: 264 Shell: Bash inxi: 3.3.11

Did you try replacing your display manager? Changing to lightdm actually made it work with my similar issue. Not really a fix, but I ran out of ideas.

Welcome to the forum :grin:

I see btrfs. Could be that you need to do something different for your swap file to make it work?

I am by no means a btrfs guru, just a suggestion.

1 Like

That’s because it’s a new issue without a solution yet. Not sure why you had to start a new thread for this, despite finding an existing one that details the exact same issue?

Check the contents of /var/log/pacman.log to identify packages updated just before you noticed the issue:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.