Black screen after Sway Install

PC: Monster Abra A5 V12.1
Cards: Nvidia GeForce GTX1050
CPU: Intel i5 7th Gen

Hello, I’m new at EndOS, I used linux(archlinux) like 4 years ago, so I cant remember everything, so I’m kinda a newbee. I read similar topics but I couldn’t sure my problem same as theirs. Because first I installed i3 edition (after installation and before reboot I installed nvidia with dkms after check with nvidia-installer-check) and there was no problem. But I wanted to install sway. I used this metod and it perfectly worked. I logout and relogin for check and again there was no problem, only it wasn’t lightdm anymore it changed gdm. I said “thats okay I can change it later” and I didn’t do nothing. But after reboot it opened with lightdm and when I try to login on sway there is a black screen, i3 still working. I tried to change dm but “welcome” app gave me error: “dm couldn’t change”. Did I installed sway with wrong way? How can I fix it?

When you get the black screen, hit the key combination of Ctrl-Alt-F3
This should bring up a TTY console window.
Log in as user, then
$ sway

If i3 comes up ok, then it is a Desktop manager problem (dgm or lightdm)
If it i3 doesn’t come up ok it is probably a Graphics Driver problem.

Doing the above might tell us which way to proceed.



Sway comes up :sweat_smile: Is this a display manager problem?

1 Like

Where are my manners? I forgot to welcome you to the forum in my first post, so.
Welcome to the EndeavourOS forum. I hope you enjoy your time here.

Yes, it is probably a desktop manager problem. So the next question is which lightdm desktop manager are you currently using? lightdm-slick-greeter or lightdm-gtk-greeter.
The following command will tell
pacman -Q | grep lightdm

List the output of the above.
I has been my experience that lightdm-slick-greeter is a little persnickety about certain hardware.
If you are now trying to boot with lightdm-slick-greeter I would suggest switching to

If you need help with that, let me know.


1 Like

if remember right sway have problem on LDM… ( no think it get fix ) ly make problem for some usr, think now it use sddm. so if have i3 + sway sddm prob best , or just use tty for sway + keep LDM for i3 .

i just point this out .


Hahah no problem, but I need to say; when I choosing OS, I saw EndeavourOS community’s friendly replies then I decided. Thanks for that.

I accidentally can change dm btw. Normally it was saying something like “change dm failed.” or something I can’t remember. But now default dm is gdm (and gnome installed now, I don’t know why) and its working fine. Thanks for answers. :slight_smile:


if gdm work for you that cool … your system your rules :+1:

:pray: i forget … Welcome to Endeavouros . hope you enjoy your system + your time in forum

EDit if you install Gnome as well ? best read . (Warning if DE)

" "

same for sway …


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.