Black screen after rebooting after NVIDIA update

With the release of the NVIDIA 555 drivers, I decided to update my system. Unfortunately, while rebooting, my screen blacked out quite a bit before the login screen was initialised. I had this issue already with the beta but I hoped that it would be fixed when it goes stable (it wasn’t). Here’s some things I tried already:

  • 1.3 and 1.4 from the NVIDIA/Troubleshooting page on the Arch wiki
  • Disabling nvidia_drm.modeset=1 (was enabled by default)
  • Running dracut --regenerate-all --force
  • Replacing nvidia-dkms with nvidia
  • Uninstalling Steam with its dependencies and lib32-nvidia-utils
  • Using the lts kernel

Nothing seems to be working for me. I have systemd-boot as my boot manager and dracut to manage initramfs. I am running EndeavourOS on Linux kernel 6.9.7 on a desktop PC with a GTX 1650 as the only graphics card (my CPU does not have integrated graphics). What do I do?

Yep the exact same thing here, i had this issue with the beta build of bazzite, proper pain the in ass, ive reverted back to using X11 for now, im on a very new GPU as well so its not just older hardware like yourself.
Nvidia 4080 here

Reverted to X11? Well, my issue doesn’t seem to be related to X11 or Wayland. Very strange.

Yeh when selecting the Session type in the login screen on the bottom left, i select X11 and that allows me to login okay without a black screen

Well my issue has nothing to do with that. I can’t even access the login GUI.

Okay must be a different issue then

Thats all i see after entering my password and username

Update: I’m able to boot into the desktop environment by running startplasma-wayland. This must be a login screen issue then or some X11 problem. However, OpenGL seems to not work with it so I can’t play any games.

hmm okay let me try that as well

Unfortunately that did not help, i tried starting it from a console session before logging
I then also tried starting a wayland session when in x11 session and this error cropped up

[luke@luke-ms7c91 ~]$ startplasma-wayland
org.kde.startup: "kdeinit5_shutdown" QList() exited with code 255
startplasma-wayland: Shutting down...
startplasmacompositor: Shutting down...
startplasmacompositor: Done.

Update: found an error message in journalctl about failing to read display number from pipe:

Can you get to a TTY or chroot from the live media and downgrade the drivers?

I haven’t updated, yet (watching Italy getting thumped), will have a go in 5-10 minutes…

These both seem like race conditions. Are you using early KMS?

Well, I can already access the terminal through’s gotta be a way to get these drivers to work. I also got this issue when downgrading to 535 btw.

I did another boot and this error didn’t show up. I added a bunch of Nvidia stuff to force_drivers on the dracut config and nothing changed.

Back in a bit, match over, going to update. @BlueStaggo why 535 not 550?

It’s because a friend told me it didn’t have the flickering issues for them (aka the issue explicit sync fixes). Because 535 didn’t work, I upgraded back to 550 and stuck to X11.

Try switching TTYs with Ctrl+Alt+Fn when this happens. I’ve seen this behavior on SDDM+Wayland where the SDDM greeter will fail to switch to the correct seat Ctrl+Alt+F5 and then Ctrl+Alt+F2 will fix it.

Btw I’m using the latest drivers 555.58 on a lot of hybrid laptops (both Intel/AMD + Nvidia) and the flicker is almost gone everywhere (there is one problematic HP Envy, but its MUX setup is a mess)

And I am back, Lenovo Legion5/RTX3070 - no issues here. issues:
Stuck notifications
Spectacle not working

Have downgraded to 550.

@BlueStaggo - IIRC 535 drivers do not run at all on the mainline 6.9.n

Oh okay i can give that a go sure. I dont have a fn key itself, but would hitting ctrl alt and f5 and then ctrl alt and f2 work?

Ha, my bad Fn was supposed to be F(n) where n is a number.

Yes, that is what I meant.