Black screen after login (hyprland)

So basically i watched a tutorial since iim not familiar to arch based systems i followed every step when i start my system the login goes smooth i type my credentials a black screen with an underscore pops up when im trying to switch to another terminal the to go back (ctrl shift f2)

black screen with a “X” mouse cursor
Im using a Nvidia gpu (it’s a bit old)

You’re going to have to provide some useful logs, dude. Are you able to access a TTY?

Okay. I saw that you edited your original post. Once you’ve switched to a tty, run

$ journalctl -b 0 | eos-sendlog

Post the resulting link.

This is the result :

Right. I had no idea that eos-sendlog doesn’t work without a graphical environment.

Try this instead:

$ journalctl -b 0 | nc 9999

You need to have openbsd-netcat installed for this to work. If you don’t have it, install it first.

Well i executed it after a fresh start here are the logs:

As far as my research got me on i guess im on a unsupported gpu so basically i have to download drivers manually ??

How did you come to that conclusion? What GPU are you on? Can you post some hardware info?

Because i tried on my main
Rtx 3060
and it worked now im trying to install it on my office desk + i’ve sm1 in reddit having the same problem but no answer


There are legacy drivers in the AUR. You just need a legacy nvidia driver for your GT 700 series. Wayland is probably not supported with the GT-710, but X11 should work fine.

Well i guess this is it wayland doesn’t support this gpu basically i tried in my laptop with a amd apu and it just works fine

Did you try installing a nvidia legacy driver from the AUR?

eos-sendlog has option --no-yad which should help in an environment without proper display support.

1 Like

yay -S nvidia-340xx

Should install the legacy nvidia driver, that supports your nvidia card.

Could you show the output of command

nvidia-inst --drivers

on the machine with Gt-710?