Black screen after Grub, no CLI available

Hi, After being affected by the grub issue I downloaded the newest iso and reinstalled EOS. After rebooting the PC I reach an unthemed grub menu and then the PC will boot to a completely black screen.

I have reproduced this several times with brand new installs and iso files. I have attempted to open the command line with CTRL + ALT + F2 and nothing appears, its just a totally black screen.

I’m at a complete loss for what to do, I’m currently posting this from the liveusb.

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

What version of the liveusb are you using?

If you are using the newest version of the liveISO shown here
and do a online install, it should work.

Older versions of the ISO install an old version of Grub and therefore fail.


looking again at the OP, I see you are using the latest ISO.
The online install should work.

Thank you for the quick reply, I am indeed using the 22_8 iso file with the online installation option.

I have seen other similar threads suggest an issue with Nvidia graphics however I am using AMD and have had no issues with drivers in the past.

I’ll attempt another install but if you have any suggestions I’d be happy to try them.

This indicates that you are re-installing on hardware which previously ran EnOS.
I am not sure what could have changed hardware wise.

Which partitioning option are you using?
Erase disk?


Yeah i’m using erase disk on the partition that the previous installation was sitting on.

Does the install complete and give you the finished notification and the “Done” button?

If so, I have no idea what is going on.


Yeah it completes without any errors and offers the restart now option, after clicking this the system will reboot, show grub and then move to a black screen without the ability to enter CLI.

Thanks for the quick replies, hopefully I’ll manage to find a fix, if I do ill be sure to post it here for anyone else who might have the issue.

I assume you are dual booting on the same storage device with another OS?


Na this is my only OS, I did end up finding a solution but I’m not totally happy with it.

I ended up just running the installer to completion another three times, the first two times the same issue occurred, the third time it managed to get into the OS without any issue, thats where I’m posting from right now.

I did notice that on the first two times (where it failed to boot into the OS and gave me the black screen) the grub menu was an unthemed grub menu. The third time (where it managed to boot into the OS) showed me a themed grub menu and worked flawlessly after that.

I have rebooted several times since then to make sure that the problem isn’t coming back and so far I’ve been in luck. It’s quite odd that the solution to the problem required me to just continuously reinstall the OS until it worked though.

I’m not sure where the issue lies, with me, with grub, with my GPU drivers or with the Endeavour installer but I hope this comment can help anyone else that stumbles into the issue, thanks for your help.

1 Like

Might be that your disk is starting to fail?
How new is it, and have you written in it a lot?

Another potential reason could be the display manager.

But for the record could you share the latest install log?

cat /var/log/endeavour-install.log | eos-sendlog

and share the returned address.

1 Like

My money is on Grub or the GPU drivers especially if the GPU is Nvidia. Is the GPU Nvidia or AMD?

Glad you got it installed, sorry for the frustration.
Hope to see you around the forums.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.