Black screen after boot, right after forcing PC to turn off in Windows shutdown

Hi! I’m new to Linux. In a few weeks ago, I installed EndeavourOS to my HDD. I selected to use BTRFS, and also installed drivers of it to my Windows installation in my SSD.

Everything worked fine. Including Windows dual-boot. I was able to copy files to my EndeavourOS partition from Windows and was able to do the reverse from EndeavourOS. Managed to install everything that I wanted to my Linux setup, except Wine(Last thing left, I tried to boot Linux to do it.).

Today, I opened up my computer and booted Windows to play some Windows games. Right after playing them, I tried to restart my PC. Again, the PC was stuck on shutting Windows down.

I’m used to it, my Windows set up gets stuck on this, even before installing EndeavourOS. Never needed to fix it because I was just able to force it to turn off using the power switch in the back of my PC. I did it a lot and never had any issues, even after I installed EndeavourOS. However, EndeavourOS shuts down fine.

However, After I did it today, I opened my PC back, tried to boot to EndeavourOS. Here’s the result, in video: https://youtu.be/NzSVGIjPBCg

Nothing happens, even if I press to Ctrl+Alt+F2/F3/F4/F5.

I tried to return back to Windows. I was able to boot. But weirdly, Windows now says “To skip disk checking, press any key within 7 seconds” every time I boot it.

However:

  1. Nothing seems to be happened besides an error in C:(Windows partition) and I can still access to Windows.

  2. I installed nothing to my SSD when I installed EndeavourOS, everything, including, if I know right, GNU GRUB. Similarly, I can also access to my Linux files from my PC.

What could be the reason of this? And is there a way to fix my Linux installation without losing anything?

Some people are reporting lately long boot times. Wait 10 minutes.

If not - create USB live disk with EOS, login and check for errors on disks, logs, etc.
https://discovery.endeavouros.com/system-rescue/arch-chroot/2022/12/

try to remove hibernate option with windows it dont really stop windows session , blocking on /boot/efi for resume.

also keep 2 profiles save config ( windows and linux) on your motherboard

My EndeavourOS setup worked with Windows’s hibernate in the past. And the fast boot option on Windows is disabled too. So I’m sure that the issue isn’t with anything about hibernating.

Do they also report a loss of display signal?

UPDATE: I can’t use mounted partition with arch-chroot, and I also can’t find the reason of this error.

Looks like you mount sdd1 and sdd2 to the same mount point /mnt

It is enough to mount only one of them, which has actual system. Or if you want both of them, mount to other mount point, example /mnt/efi

If you need more info:
https://wiki.archlinux.org/title/Chroot#Prepare_new_root_location

I just only mounted ssd2, gave the same error.

UPDATE: I thought that the issue wasn’t with drive. I think I was right, because I tried to use fsck for it but it gave no errors and didn’t even find anything to fix.

SOLVED:

Did…
…on linux:
# fsck /dev/sdd2
…on Windows:
chkdsk C:/ /f /r

Windows was using the drives while I was closing so it damaged a few partitions.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.