Black Ops 3 - Friends Unable to Join My Lobby

I have played Call of Duty: Black Ops 3 (BO3) Zombies with friends before on Windows 10.

I’ve been playing with friends on BO3 Zombies recently and one of two would always host since they’re on the same home network.
Trouble comes in when me or the other guy tries to host.
I would like to resolve possible issues on my end to be sure.

I suspect my NAT Type may be the issue.
I’ve seen in BO3’s Menu>Options>Network, there is an entry for “Nat Type” it suggests changes to enact to change the NAT Type to “Open”

I am very sure that I have port forwarded port number 27017 as stated in the entry.
I have enabled UPnP within my router and added my computer’s local IP address in the DMZ.
After making sure all of those settings are correct, BO3 still lists my NAT Type as “Moderate”.

Could there be steps needed to be performed in my operating system to change the NAT Type to “Open” or to make it easier for my friends to connect to my lobby?

Was this done on the router? Also, what router model do you have? Do you have any downstream repeaters/routers/switches that have a firewall? i.e. “Double-NATted”

I have never played, but is this the only port that is needed to be open and is it using UDP/TCP packets?

There is no need to use DMZ and can be very harmful as you are putting your PC outside of your firewalled system.

Yes, you may have firewalld or UFW or other firewall system installed. If you are running a systemd system do sudo systemctl status and look to see if you have firewalld or UFW active. If so, we can help you from there. Also, try using canyouseeme website to see if your port is actually forwarded or not. You can also see if it is just your PC by using NetworkManager on Windows or a port scanning software on linux on another PC behind your firewall to see if your PCs port is open and available.

Yes, this was done on the router,
Model: Hitron CGNM-2250. The PC I’m playing on is directly connected to this router/switch.
I am in an apartment, so I’m unsure if there is anything else downstream. I hope that the isn’t anything.

According to the in-game menu, that is the port it checks, however the game’s website does list many others. Those others have been opened in the router as well. Those ranges of ports use a mix of UDP and TCP packets.

An understandable concern, I did this because the same in-game menu suggested that action.
Of course that doesn’t mean it’s a good option hahahaha.

I am running on systemd and I can confirm that I do have firewalld as my active firewall program.
I’ve tried using canyouseeme on all the range of ports I have opened on my router/switch.
None can be seen by that service. This could mean that the ports aren’t properly opened somewhere in the chain, right?

I don’t have a Windows system on my network, however I do have a laptop running on Debian 11 I can use to scan the network, however I’m not familiar with port scanning software on Linux.
I do see that there is a program called NetworkManger already installed on my system, perhaps that’s the program you’re referring to?

OK, it is more than likely your firewall is dropping packets on this port. I am assuming you have a GUI installed. i.e. GNOME/KDE/XFCE/Budgie…

If so do:

yay -S firewall-config

Once installed browse the menu for Firewall Configurator or some such. It defaults sets you up in the “public” zone (I am not 100% this is what it is called), so click on the custom ports and add it to your list. Then click on the button that makes it permanent. Then do:

sudo systemctl restart firewalld
sudo systemctl status firewalld

This should show active. Then check canyouseeme again. If not, check out this tutorial on firewalld on Arch.

I hope that helps.


I definitely have firewall-config installed on my system.
Within the public zone and ports tab of that zone I have set the permanent configuration with the necessary ports and protocols.

Running canyouseeme again still says it cannot see my ports.

EDIT: I have found that there is also a “Port Forwarding” tab in firewall-config.
I added my ports to that tab and saved as permanent. Same results.

OK, on your Debian 11 system install Angry-IP Scanner and check to see if port 27017 is open. If that is the case, then it may be that either your ISP or Apartment complex has an upstream firewall blocking those ports and you may need to see what ports are not blocked and do a port forwarding scenario to work around that.

No, the NetworkManager I am referring to is a Windows program similar to Angry-IP Scanner. NetworkManager on linux is what many systems use to control your ethernet connections and wireless connections (amongst other network connections).

I rechecked my port forwarding configuration within my router, it seems like I had the wrong local IP for the ports I wanted to open for my desktop system.

I appreciate your time in helping me resolve this issue, even if I was mainly my lack of attention of my router configuration.

Although my issue seems to be resolved, I am confused that this program and canyouseeme both list that my ports are unreachable.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.