Bitwarden Password manager issue

Starting today I cannot Sync, edit or add items in the app.

Version 2024.4.0
Shell 28.3.0
Renderer 120.0.6099.291
Node 18.18.2
Architecture x64

[panta@EVL340 ~]$ pacman -Qi bitwarden
Name : bitwarden
Version : 2024.4.0-1
Description : A secure and free password manager for all of your devices
Architecture : x86_64
Licenses : GPL3
Groups : None
Provides : None
Depends On : electron28 libnotify libsecret libxtst libxss libnss_nis
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 34.30 MiB
Packager : Alexander Epaneshnikov
Build Date : Thu 11 Apr 2024 09:45:13 AM
Install Date : Mon 15 Apr 2024 08:58:01 AM
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

Sync failed_Bitwarden 1

Looks like “Failed to decode access token: JWT must have 3 parts” is from the latest update

So, far I found those sources that suggest a fix in Ubuntu ( and that doesn’t seam to work for everyone.

Also, in here ( janvkn said: “… I had to rollback to 2024.3.0 and remove my ~/.config/Bitwarden directory to get it to work…”

So, any additional info on that for EOS?

I’m a newb. So, how to downgrade?

Have you tried to delete the bitwarden config?

rm -rf $HOME/.config/Bitwarden

Just did. and lost what I have cached… Now is endless loading since couldn’t sync.
No, it did help. No sync.

Just installed bitwarden from the Official Repos. Opened and synced just fine.

Make sure you have these installed:

electron28  libnotify  libsecret  libxtst  libxss  libnss_nis

You can verify by simply doing:

yay -Qi bitwarden

You should have them installed, but you may want to delete the config folder again then do

yay -Rs bitwarden && yay -S bitwarden
1 Like

ok. It was worth a try.

Anyways, I just installed the arch bitwarden package 2024.4.0-1 and it works fine. No issue with syncing.

You may want to delete and reinstall bitwarden.

did all that in the order you suggested. After re-installing still no sync :frowning:

Interesting how Bitwarden detects that I have logged using the app

But still cant sync

Stupid question: have you logged out with the app? The app has a specific “logout” button.

You need to install downgrade

and then run

downgrade bitwarden

in a terminal

1 Like

This really shouldn’t matter since they said they’ve deleted the config folder a few times. But I guess it might be worth a try.

Only other thing I can think of is to test a new temporary desktop user to see if that works. If it does, then copy the config folder from that user to the current user and maybe things will work.

The appimage works fine on my end:

Screenshot from 2024-04-18 00-23-22

As per my first/opening post the only difference in the app image is the Shell version I have is 28.3.0

Also, I have this app for over an year. Just today decided to stop working.
From the link I posted I read about this issue happening with MS Win10 users… Bitwarden closed it on their bug report site (

I’ll try it… First have to figure out how to add users…

Ah… What?

To confirm: I meant add a login user for your desktop/laptop, not for Bitwarden. :eyes:
You can do it through the terminal or through the system settings for your DE/WM.

Terminal method can be found here:

useradd -m tempUsername

Also works fine here, …alternative use a Bitwarden Browser Plugin.
You can detach that and use it like the GUI version, as long as the native one is broken.

like pebcak said, the appimage works fine. i would recommend trying it out to see if that works for you

@Limen , It seems you may have exactly the same issue I got: look in the “app.log” file, in the bitwarden config directory. If each time the app try to sync you have this line :

[error] Unable to fetch ServerConfig: Failed to decode access token: JWT must have 3 parts

Then THIS is the official answer from Bitwarden (I received it yesterday after contacting their helpdesk):

The short version is that Bitwarden recently introduced changes in how data was stored in an operating system’s secure storage system, which varies by operating system. In certain Linux configurations, there is a bug that can lead to the behavior you are seeing. This is being actively worked on by the team at Bitwarden, and I suspect this will be addressed soon in a future update. For more information, you can follow the progress being made here in our GitHub:

In the meantime, I recommend using an alternative, such as the Bitwarden browser extension or the Bitwarden Web App ( Apologies for any inconvenience.

I am actually accessing the vault through the web browser, until they resolve the bug.

Thank you.
Actually I am using the Firefox extension. Works, great for me.
I also found more info. From here ( I found out that his is something to do with Java programing and this application (

Should be able to survive until the fix-update :slight_smile:

I have this issue now. No issues in my previous EOS KDE install. But in EOS Cinnamon, I have the exact same issue as the OP. Hopefully this will be addressed by a Bitwarden update soon. Using browser extension for the time being.